summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 08:57:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 09:10:31 +0200
commitac2e78d68764e0082394825d52b4a18f9d764ac6 (patch)
treed85dbef71d6ad367f2616c36b543c4de4ad864d7
parentdev-libs/FBGEMM: add to tree (diff)
downloadgentoo-ac2e78d68764e0082394825d52b4a18f9d764ac6.tar.gz
gentoo-ac2e78d68764e0082394825d52b4a18f9d764ac6.tar.bz2
gentoo-ac2e78d68764e0082394825d52b4a18f9d764ac6.zip
dev-python/pytest-skip-markers: Fix dependencies, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r1.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..729cee124881
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-declarative-requirements[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}