summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-06 18:24:34 +0000
committerSam James <sam@gentoo.org>2022-01-06 18:25:17 +0000
commitac360dbea7634a066036ee3e2d976bf91c4f486e (patch)
treecae26c813ff827f58881d9f925b57401173d991f
parentdev-lang/jsonnet: Version bump to 0.18.0 (diff)
downloadgentoo-ac360dbe.tar.gz
gentoo-ac360dbe.tar.bz2
gentoo-ac360dbe.zip
dev-python/pygments: add 2.11.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.11.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 7a9394cedd0a..e01e1cf81987 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,4 @@
DIST Pygments-2.10.0.tar.gz 4052321 BLAKE2B 003d13344a2c5fe448a23d7bb45a401dc839cac10be262f5831c9547444d395811c92b74d1b18663a11a2e6cedf29b5a74cbd75267157429d61375bd9df6eb49 SHA512 28fdf35e333717795f199e0ef936d6df16ac0752324839ac36cabd2f9f6759a57663527d37f1c2f470258d63c3cf190f6dd4b631b21c849fc76575036fbdae12
DIST Pygments-2.11.0.tar.gz 4157814 BLAKE2B de70a1de48083a9a0f281e4eb7f164cb551bd2fa2e7682c26c4513e1ebadf9da4ba6b2ccb50cc16955df484d313dff2b0431d6de2f5590c59c775f9ebd3884db SHA512 761b722cdcbc41bc730843e8120ae3c0d634db9918c1c1870d89b79002b55f245c896ed9301c44b665e573a8584d5f8504623fe9d4c63820b57a2cfcae576b33
DIST Pygments-2.11.1.tar.gz 4206490 BLAKE2B 116efe4eb71b276eb860a1de04191b8cb01abc0c879a764715d6d6290a523360c7b195e81a6f32516ad5830410534f2ad01498393c36959ce934e1ccf1520fb9 SHA512 77bc1c7fa10ce945591f6d0546f0e9da8d65df58954348fe3b5a4dd8628c9697bd500e74eec3e2a095c5cb3378b8dee1cb0396cd52d7c36c0f2ca719a6d023b9
+DIST Pygments-2.11.2.tar.gz 4206258 BLAKE2B d9b7ac03ab564051df8eebf390586387d824584f5485eb6af2048cec181412fe2812409251c9c042421125a2579d9ac6de4006c1c0de025ed7b010482482b9f9 SHA512 606ff0c35fa47882f4c5c3794827132e1ee6ccbb4895ae858f9c93ea0c92b73163c9f4d630b51a8bb782ba0b4944a66d1059ad5d017d3191a0a5b30c1e5b8f9f
diff --git a/dev-python/pygments/pygments-2.11.2.ebuild b/dev-python/pygments/pygments-2.11.2.ebuild
new file mode 100644
index 000000000000..d278cefb452e
--- /dev/null
+++ b/dev-python/pygments/pygments-2.11.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc \
+ dev-python/wcag-contrast-ratio
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}