summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2022-05-06 11:58:01 +0300
committerSam James <sam@gentoo.org>2022-05-07 06:03:44 +0100
commitac6191ed2fff5b6070ff1efb7128f70b501176d0 (patch)
treefe6a2fb571d91875c67c4b7eac5d15659a37b0e0
parentsys-fs/xwmfs: removal of old version 0.90 (diff)
downloadgentoo-ac6191ed.tar.gz
gentoo-ac6191ed.tar.bz2
gentoo-ac6191ed.zip
sys-libs/libxcrypt: fix cross + system dependencies
Starting with the v4.4.28 ebuild, libxcrypt supports cross-* builds so we need to ensure the dependencies are properly specified, for eg: aarch64-cros-linux-gnu/libxcrypt needs to depend on the aarch64-cros-linux-gnu/glibc instead of plain sys-libs/glibc. Closes: https://bugs.gentoo.org/842906 Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/25348 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
index f4a2b797141a..50aec10c1952 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
@@ -39,10 +39,10 @@ is_cross() {
DEPEND="system? (
elibc_glibc? (
- sys-libs/glibc[-crypt(+)]
- !sys-libs/glibc[crypt(+)]
+ ${CATEGORY}/glibc[-crypt(+)]
+ !${CATEGORY}/glibc[crypt(+)]
)
- !sys-libs/musl
+ !${CATEGORY}/musl
)
"
RDEPEND="${DEPEND}"