summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 21:44:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-12 21:47:24 +0200
commitac65dfd7c3198cc954b571216dea310361429813 (patch)
tree4f0a69f65b3f28ae57a8a7aa6087b7ed1b7c879d
parentdev-libs/hyperscan: Add missing PYTHON_REQUIRED_USE (diff)
downloadgentoo-ac65dfd7.tar.gz
gentoo-ac65dfd7.tar.bz2
gentoo-ac65dfd7.zip
dev-libs/libcharon: Add missing PYTHON_*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/libcharon/libcharon-3.4.1.ebuild6
-rw-r--r--dev-libs/libcharon/libcharon-3.6.0-r1.ebuild (renamed from dev-libs/libcharon/libcharon-3.6.0.ebuild)6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/libcharon/libcharon-3.4.1.ebuild b/dev-libs/libcharon/libcharon-3.4.1.ebuild
index ca9cf5b39c66..1edcc8fe92b5 100644
--- a/dev-libs/libcharon/libcharon-3.4.1.ebuild
+++ b/dev-libs/libcharon/libcharon-3.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,5 +16,9 @@ LICENSE="LGPL-3"
SLOT="0/3"
KEYWORDS="~amd64 ~x86"
IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND=${PYTHON_DEPS}
+DEPEND=${RDEPEND}
S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/dev-libs/libcharon/libcharon-3.6.0.ebuild b/dev-libs/libcharon/libcharon-3.6.0-r1.ebuild
index 503dd3878a83..1edcc8fe92b5 100644
--- a/dev-libs/libcharon/libcharon-3.6.0.ebuild
+++ b/dev-libs/libcharon/libcharon-3.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,5 +16,9 @@ LICENSE="LGPL-3"
SLOT="0/3"
KEYWORDS="~amd64 ~x86"
IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND=${PYTHON_DEPS}
+DEPEND=${RDEPEND}
S="${WORKDIR}/${MY_PN}-${PV}"