summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-03 06:02:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-03 06:53:05 +0100
commitacaddc143323e5900bbb60b66c51d38df801188d (patch)
tree44b720c1714d253be29339b18f2c721c80180102
parentdev-python/google-auth: Bump to 2.16.2 (diff)
downloadgentoo-acaddc14.tar.gz
gentoo-acaddc14.tar.bz2
gentoo-acaddc14.zip
dev-python/mdit-py-plugins: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mdit-py-plugins/Manifest1
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index 470ea8f2f7fb..93a6bb4664e4 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,2 +1,3 @@
DIST mdit-py-plugins-0.3.3.gh.tar.gz 57366 BLAKE2B 60b53c6aa404a22296da122b6528491fa7dc52c4b485dea1b0c26c486cd04bf495948e03c40d54ac9d436431ab1154f51af90c84762f96d87984b74718a736a9 SHA512 a32a4a7004368af924c0876106e10a55a2f361a18db127a45080779bc39fb709ca274febbb4c4d5e872357e99bd8161e6c760783793516011da5f963368fa637
DIST mdit-py-plugins-0.3.4.gh.tar.gz 59538 BLAKE2B 7046c2b8b5b117612a71c1a4894c7e3e49a161b5375fde13ec61c4a00c2bf5824505cb5639b70a3c58d7c9629e68bf794c950b5a28470392487965cd94f3e9a9 SHA512 e36b0ee0aca95d60c27a577e1c4bde9832d633ca84fb740f16a37dd63ece0a77005f8e3d03360ed0c92de57d3f656a8f76ab76642d8da3e5ac1d65384ee18d84
+DIST mdit-py-plugins-0.3.5.gh.tar.gz 59757 BLAKE2B bad78ec811d238bafd83c9d1bbd6e0bcac3b70cd87f52b215966e836d4c2a35715804fa1c7d3671de81713c4e169ad4bb6d9dcdf741f617544772d06f8e3ae56 SHA512 6cb153d8ccff8fa3f94731606ad5dd1c06954d95519ac77b6de477e04b878f84fb059052906bdea5d798be3de49733a909cb553107255a61cde6dd1c6c72d4d2
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.5.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.5.ebuild
new file mode 100644
index 000000000000..9dcd74e0c13e
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest