summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-16 05:22:30 +0000
committerSam James <sam@gentoo.org>2024-03-16 05:23:11 +0000
commitacc020e3ee4ade729f99d49d5ee43f90a8d510e1 (patch)
tree6e1235aa4d8432f85f28cd79dd8f9cb889d96c73
parentapp-portage/elt-patches: Stabilize 20240213 ppc64, #927048 (diff)
downloadgentoo-acc020e3ee4ade729f99d49d5ee43f90a8d510e1.tar.gz
gentoo-acc020e3ee4ade729f99d49d5ee43f90a8d510e1.tar.bz2
gentoo-acc020e3ee4ade729f99d49d5ee43f90a8d510e1.zip
dev-libs/json-c: don't use Valgrind automagically in tests
Closes: https://bugs.gentoo.org/927027 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/json-c/json-c-0.17.ebuild5
-rw-r--r--dev-libs/json-c/json-c-9999.ebuild3
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/json-c/json-c-0.17.ebuild b/dev-libs/json-c/json-c-0.17.ebuild
index 4f44e489c9b1..6fb6f4f13f3a 100644
--- a/dev-libs/json-c/json-c-0.17.ebuild
+++ b/dev-libs/json-c/json-c-0.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,6 +19,9 @@ MULTILIB_WRAPPED_HEADERS=(
)
multilib_src_configure() {
+ # Tests use Valgrind automagically otherwise (bug #927027)
+ export USE_VALGRIND=0
+
local mycmakeargs=(
# apps are not installed, so disable unconditionally.
# https://github.com/json-c/json-c/blob/json-c-0.17-20230812/apps/CMakeLists.txt#L119...L121
diff --git a/dev-libs/json-c/json-c-9999.ebuild b/dev-libs/json-c/json-c-9999.ebuild
index 29dc876b223b..2ee46fcafda5 100644
--- a/dev-libs/json-c/json-c-9999.ebuild
+++ b/dev-libs/json-c/json-c-9999.ebuild
@@ -20,6 +20,9 @@ MULTILIB_WRAPPED_HEADERS=(
)
multilib_src_configure() {
+ # Tests use Valgrind automagically otherwise (bug #927027)
+ export USE_VALGRIND=0
+
local mycmakeargs=(
# apps are not installed, so disable unconditionally.
# https://github.com/json-c/json-c/blob/json-c-0.17-20230812/apps/CMakeLists.txt#L119...L121