summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-03 07:09:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-03 07:09:10 +0100
commitace0a7714d7170f2911187f42827b68e2e578d4e (patch)
tree780804d2d5280cc37a8b6cb1b04b8376f856ac43
parentgames-kids/tuxmathscrabble: Remove last-rited pkg (diff)
downloadgentoo-ace0a771.tar.gz
gentoo-ace0a771.tar.bz2
gentoo-ace0a771.zip
games-action/accelerator3d: Remove last-rited pkg
Closes: https://bugs.gentoo.org/703762 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-action/accelerator3d/Manifest1
-rw-r--r--games-action/accelerator3d/accelerator3d-0.1.1-r3.ebuild47
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch53
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch11
-rw-r--r--games-action/accelerator3d/metadata.xml11
-rw-r--r--profiles/package.mask5
6 files changed, 0 insertions, 128 deletions
diff --git a/games-action/accelerator3d/Manifest b/games-action/accelerator3d/Manifest
deleted file mode 100644
index adcbb98cf6ea..000000000000
--- a/games-action/accelerator3d/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST accelerator-0.1.1.tar.bz2 1183838 BLAKE2B 8c7b888e4eadc0a1ed63745904db94757cfa73557664e0b2a7f7c8960990eb82991be9b1b42cb0d60f3af113867a2a02fb9304bd97f7658fec7d86efe5747c34 SHA512 f4321beb5f5b61c10d0b275321641ec173636267ae08cf88f7a2ecaaf0799cfe6593cbc7343c8ebfa72853c59773841295b1aca9a0ac0ef510de390107aa01da
diff --git a/games-action/accelerator3d/accelerator3d-0.1.1-r3.ebuild b/games-action/accelerator3d/accelerator3d-0.1.1-r3.ebuild
deleted file mode 100644
index 2013913e62fc..000000000000
--- a/games-action/accelerator3d/accelerator3d-0.1.1-r3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit desktop python-r1
-
-DESCRIPTION="Fast-paced, 3D, first-person shoot/dodge-'em-up, in the vain of Tempest or n2o"
-HOMEPAGE="http://accelerator3d.sourceforge.net/"
-SRC_URI="mirror://sourceforge/accelerator3d/accelerator-${PV}.tar.bz2"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- dev-python/pygame[${PYTHON_USEDEP}]
- dev-python/pyode[${PYTHON_USEDEP}]
- dev-python/pyopengl[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${PN}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo-paths.patch
- "${FILESDIR}"/${P}-gllightmodel.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e "s:@GENTOO_DATADIR@:${EPREFIX}/usr/share/${PN}:" \
- accelerator.py || die
-}
-
-src_install() {
- python_foreach_impl python_newscript accelerator.py accelerator
-
- insinto /usr/share/${PN}
- doins -r gfx/. snd/.
- einstalldocs
- make_desktop_entry accelerator
-}
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch b/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch
deleted file mode 100644
index 526fa678fdbc..000000000000
--- a/games-action/accelerator3d/files/accelerator3d-0.1.1-gentoo-paths.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/accelerator.py 2006-04-18 21:51:28.000000000 +0200
-+++ b/accelerator.py 2006-04-18 22:07:28.000000000 +0200
-@@ -72,7 +72,7 @@
- # default parameters on it (min/mag filters, wrapping).
- def __init__(self,texfile,mipmap = False):
- global activeTexture
-- filename = os.path.join('gfx',texfile)
-+ filename = os.path.join('@GENTOO_DATADIR@',texfile)
- image = pygame.image.load(filename)
- data = pygame.image.tostring(image,'RGBX')
- self.__texref = glGenTextures(1)
-@@ -599,8 +599,8 @@
- for i in xrange(len(self.__menu[j][0])):
- font.addString(self.__menu[j][0][i])
- if (soundon):
-- self.__browsesound = pygame.mixer.Sound(os.path.join('snd','menu_browse.wav'))
-- self.__selectsound = pygame.mixer.Sound(os.path.join('snd','menu_select.wav'))
-+ self.__browsesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','menu_browse.wav'))
-+ self.__selectsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','menu_select.wav'))
-
- def doLoop(self):
- global elapsed, z_increment, font
-@@ -792,19 +792,19 @@
-
- # sound!
- if soundon:
-- self.__shootsound = pygame.mixer.Sound(os.path.join('snd','shoot.wav'))
-- self.__cluonsound = pygame.mixer.Sound(os.path.join('snd','cluon.wav'))
-- self.__bogonsound = pygame.mixer.Sound(os.path.join('snd','bogon.wav'))
-- self.__shipdeadsound = pygame.mixer.Sound(os.path.join('snd','ship_explode.wav'))
-- self.__shocksound = pygame.mixer.Sound(os.path.join('snd','electricshock.wav'))
-- self.__thudsound = pygame.mixer.Sound(os.path.join('snd','thud.wav'))
-- self.__enginesound = pygame.mixer.Sound(os.path.join('snd','engine.wav'))
-- self.__chargesound = pygame.mixer.Sound(os.path.join('snd','neon.wav'))
-+ self.__shootsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','shoot.wav'))
-+ self.__cluonsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','cluon.wav'))
-+ self.__bogonsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','bogon.wav'))
-+ self.__shipdeadsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','ship_explode.wav'))
-+ self.__shocksound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','electricshock.wav'))
-+ self.__thudsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','thud.wav'))
-+ self.__enginesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','engine.wav'))
-+ self.__chargesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','neon.wav'))
- self.__chargeplaying = False
-- self.__scrapesound = pygame.mixer.Sound(os.path.join('snd','scrape.wav'))
-+ self.__scrapesound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','scrape.wav'))
- self.__scrapeplaying = False
-- self.__slamsound = pygame.mixer.Sound(os.path.join('snd','slam.wav'))
-- self.__phlogsound = pygame.mixer.Sound(os.path.join('snd','phlogiston.wav'))
-+ self.__slamsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','slam.wav'))
-+ self.__phlogsound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@','phlogiston.wav'))
-
- # reserve channel 0 for bullet sounds
- pygame.mixer.set_reserved(2)
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch b/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
deleted file mode 100644
index 31d0a8b5b4c5..000000000000
--- a/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/accelerator.py
-+++ b/accelerator.py
-@@ -274,7 +274,7 @@
- glColorMaterial(GL_FRONT,GL_AMBIENT_AND_DIFFUSE)
- glMaterialfv(GL_FRONT,GL_SHININESS,128)
- glMaterialfv(GL_FRONT,GL_SPECULAR,(0.5,0.5,0.5,1))
-- glLightModel(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
-+ glLightModeli(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
- glEnable(GL_LINE_SMOOTH)
- glEnable(GL_NORMALIZE)
- #glPolygonMode(GL_FRONT,GL_LINE)
diff --git a/games-action/accelerator3d/metadata.xml b/games-action/accelerator3d/metadata.xml
deleted file mode 100644
index eaa5ae72c1f2..000000000000
--- a/games-action/accelerator3d/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">accelerator3d</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 10ff49cd33d7..c595653daa54 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -774,11 +774,6 @@ games-arcade/pycadia
# Removal in 30 days. Bug #703764.
games-arcade/bub-n-bros
-# David Seifert <soap@gentoo.org> (2019-12-25)
-# Py2 only, upstream abandoned since 2005.
-# Removal in 30 days. Bug #703762.
-games-action/accelerator3d
-
# Tomáš Mózes <hydrapolic@gentoo.org> (2019-12-19)
# Needs more testing.
=app-emulation/xen-4.13.0