summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 15:26:47 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 18:02:25 +0200
commitacf5be92ebd8075db33638e65673869c1dabe9ff (patch)
tree48f40da8c1a81980fa9cc207bdd0cb17b6130046
parentprofiles: mask kde-apps/mplayerthumbs for removal (diff)
downloadgentoo-acf5be92.tar.gz
gentoo-acf5be92.tar.bz2
gentoo-acf5be92.zip
dev-python/lz4: Bump
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-0.8.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index b88f127de41c..63a35a8acdf2 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,2 +1,3 @@
DIST lz4-0.6.1.tar.gz 19830 SHA256 590d1dca53b743e7fc38190fa674b20eea87d793a70910984ff58a6f6cf20160 SHA512 c41f02f9ba855256e057141db7f11b0097f373cfcbf7bb9cf3b9337aebcd30bfe36ae3d643f3e5f594351f97d3e80c75b15c7ce1e3e2c7536f6daab811a642d8 WHIRLPOOL 1b7e081fe9994fe478965b9522b20146f097bdac7ff5bd491d4d05c0f8854eaff4144fe31089f8689d27b6dc3b6728bf00aa58e8ddd7bf0d4806dea52f27b736
DIST lz4-0.7.0.tar.gz 26786 SHA256 cd225744298568fd217577fc14a326a24835412374dadb5060db48f1af43eb48 SHA512 fd7adc4919e70259e5b23b15919c4932354a4518360315a8d6c15c58cdccf21257fb6069bdf20e86a2461f254b50f4abd7296330fd77647ecc2ca49500eedd11 WHIRLPOOL 51e2200e72b3a5d222d6f9e5ec3ed14fc9f026a62943088d237a60c0b3d61f9862450aa63cfcacf2a7c5fb506025da82c34102c25bf54ad8e8fb938bfe570773
+DIST lz4-0.8.2.tar.gz 30818 SHA256 6bf49061d73d69c453e892ace4586b99ccffc7de558f921d18b9418235692ac7 SHA512 e516d5c3309f214fa422b040a0aacdda079395624dd4f5548ed7af637b1594012aac75b309cef260b41c10a623410f815fc089b54ca5d80955d5f2ead12841b1 WHIRLPOOL 0a91c5befd9e8d1593ffdf6e102ec4dfa0ac921530e5c570748fdd1be4e0d1a4367792d9226b92215eae764da4107f4370fbf35c5e3b0793d96afc07f330434b
diff --git a/dev-python/lz4/lz4-0.8.2.ebuild b/dev-python/lz4/lz4-0.8.2.ebuild
new file mode 100644
index 000000000000..57032f96e888
--- /dev/null
+++ b/dev-python/lz4/lz4-0.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.python.org/pypi/lz4 https://github.com/steeve/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Tests still excluded by upstream
+
+python_prepare_all() {
+ sed \
+ -e '/nose/s:setup_requires:test_requires:g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}