summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-03 07:44:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-03 08:08:53 +0200
commitacf5e9d9245abf22f33bb5784ab00ac6c210413f (patch)
tree925f5a751af2e2494c835e2393515220f544111d
parentdev-python/rapidfuzz: Bump to 3.2.0 (diff)
downloadgentoo-acf5e9d9245abf22f33bb5784ab00ac6c210413f.tar.gz
gentoo-acf5e9d9245abf22f33bb5784ab00ac6c210413f.tar.bz2
gentoo-acf5e9d9245abf22f33bb5784ab00ac6c210413f.zip
dev-python/fitsio: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/fitsio-1.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index dd42d376525f..8b1b00768f8f 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1 +1,2 @@
DIST fitsio-1.1.10.gh.tar.gz 5052842 BLAKE2B 1d0fb90fa23b3adf1ab172c89f9475b59d1bc909b225129c923bd27391af2844d4b56134568ed07124b9152000fb1325a2225997048d18aa596246d609888b28 SHA512 d0e28f1892640404a2514832e1d68ac202de4c3d3a840c783e6eb3de381f2180136eaec856bd7ab1b236b67c273417a137121137f6d1e66ee6bb2becdc522fa6
+DIST fitsio-1.2.0.gh.tar.gz 4582716 BLAKE2B a395318b7ae3f52f7c764dae81b9ba9e305cf92e140d7ee015e235c1448a8fb7b2f87ec6132b7d4322f5a468384f8b6a9a33382d0d9d2adc8924e9d3843d9901 SHA512 d701534d8615382dbe8e4134e0b47a2568194e746b75b6c0dc9172d30c79d2cd70052364b18506d275360c82811a7062832bb6f6d7bfb4b3be6ef51b19b62a95
diff --git a/dev-python/fitsio/fitsio-1.2.0.ebuild b/dev-python/fitsio/fitsio-1.2.0.ebuild
new file mode 100644
index 000000000000..543a39335611
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="
+ https://github.com/esheldon/fitsio/
+ https://pypi.org/project/fitsio/
+"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+export FITSIO_USE_SYSTEM_FITSIO=1
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}