summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-02 11:29:44 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-02 11:48:26 +0200
commitad029930cb43b900dbe6c2ea0f655e160507151e (patch)
treea34f28c569f6ada3eb93b652d9be4c2f8210c681
parentmedia-gfx/nvidia-texture-tools: Drop qt4 automafic dep and cuda USE (diff)
downloadgentoo-ad029930cb43b900dbe6c2ea0f655e160507151e.tar.gz
gentoo-ad029930cb43b900dbe6c2ea0f655e160507151e.tar.bz2
gentoo-ad029930cb43b900dbe6c2ea0f655e160507151e.zip
net-analyzer/nikto: Bump to ebuild from Pentoo overlay
This also solves the bogus usage of net-libs/libwhisker, that is dead and is not really compatible with nikto (#533900 by Anton Bolshakov) Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--net-analyzer/nikto/Manifest1
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20180122.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index e5ad7a507e47..7d02e06ffea8 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1,2 +1,3 @@
DIST nikto-1.36.tar.gz 206921 BLAKE2B ed6cc343ddccd8d35a7df566c5facb91b31fa9ec1697bb962fb7a0fdf3bc396a95c60997267fdca929b6af2e599f1535a223bf04ccb53da485ce409f8bc4391f SHA512 e340eebc8323a689b1fe8358626f90d822f4eea4aaeba44c64f68c758fccdec7c3d5896b93739128b1b53429967d4e66ccb08b880066e0c63bed4e2748f94a45
DIST nikto-2.1.5.tar.bz2 311580 BLAKE2B 5441953ed4f778efd06c784a5f608f4a00f61f1462a6fd637b5d490b84aecf4fc0d39cb2780469e00ba1a5c75c2ead63c2cb45a6f4b7c59ad243a671122264db SHA512 623b0fa923c05ecc4b69087321b544941f09b4d84fb7a32f6970e2ea42b2018f2c4e2d1cd0fabfc1c99a2ca7b57fd8c0d9f5f13c86e7eb102f00bdfd3062a95f
+DIST nikto-2.1.6_p20180122.tar.gz 511615 BLAKE2B 0937a5a52ae79e00da5bc53b089166cb2fc5cdf8311c4db55e421ddb44c22e31a9a964b02d75995c74b144d8fe05046895c4e54cfa7500aecd5d36787105a417 SHA512 4b9cae08146cefcfe4e929385631062f27cd13f5e516ec50fa9f9804a677a4a8846bc0f5de99bc1a25ec58ea8e2889bfa5953f8ca9cd7152e7b95b05861cac91
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20180122.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20180122.ebuild
new file mode 100644
index 000000000000..167752e379bc
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20180122.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="http://www.cirt.net/Nikto2"
+COMMIT="b8454661c4dc9249cb515311cb2a80906a0a4b7a"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ssl"
+
+# nikto provie its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-JSON-PP
+ net-analyzer/nmap
+ ssl? (
+ dev-libs/openssl:0=
+ dev-perl/Net-SSLeay
+ )
+"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:config.txt:nikto.conf:g' plugins/* || die
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/*.txt
+ dodoc docs/nikto_manual.html
+}