summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-12 21:28:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-12 23:16:53 +0100
commitad2999b9867ced55409b0a23860de10a637468c4 (patch)
tree393ea5b5c283d5881a95ae714cf36bb7e68d1c25
parentsys-apps/readahead-list: remove old (diff)
downloadgentoo-ad2999b9867ced55409b0a23860de10a637468c4.tar.gz
gentoo-ad2999b9867ced55409b0a23860de10a637468c4.tar.bz2
gentoo-ad2999b9867ced55409b0a23860de10a637468c4.zip
media-libs/libxspf: Drop USE=doc, depends on qthelp:4
Closes: https://bugs.gentoo.org/398881 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch8
-rw-r--r--media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch4
-rw-r--r--media-libs/libxspf/libxspf-1.2.0.ebuild42
3 files changed, 28 insertions, 26 deletions
diff --git a/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch b/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch
index fa16b589df30..668e8af1be16 100644
--- a/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch
+++ b/media-libs/libxspf/files/libxspf-1.2.0-gcc44.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/261604
---- test/OfficialSuite.cpp
-+++ test/OfficialSuite.cpp
+--- a/test/OfficialSuite.cpp
++++ b/test/OfficialSuite.cpp
@@ -21,6 +21,7 @@
* Sebastian Pipping, sping@xiph.org
*/
@@ -10,8 +10,8 @@ http://bugs.gentoo.org/261604
#include "OfficialSuite.h"
#include <xspf/XspfReaderCallback.h>
using namespace Xspf;
---- test/ProjectOpus/ProjectOpusSuite.cpp
-+++ test/ProjectOpus/ProjectOpusSuite.cpp
+--- a/test/ProjectOpus/ProjectOpusSuite.cpp
++++ b/test/ProjectOpus/ProjectOpusSuite.cpp
@@ -21,6 +21,7 @@
* Sebastian Pipping, sping@xiph.org
*/
diff --git a/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch b/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch
index b408416e7ef7..76c0dca755f8 100644
--- a/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch
+++ b/media-libs/libxspf/files/libxspf-1.2.0-gcc47.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/421745
---- examples/read/read.cpp
-+++ examples/read/read.cpp
+--- a/examples/read/read.cpp
++++ b/examples/read/read.cpp
@@ -43,6 +43,7 @@
#include <cstdio>
#include <cstdlib> // MAX_PATH
diff --git a/media-libs/libxspf/libxspf-1.2.0.ebuild b/media-libs/libxspf/libxspf-1.2.0.ebuild
index a7c71fb4d12b..fa7f0ecfa6f8 100644
--- a/media-libs/libxspf/libxspf-1.2.0.ebuild
+++ b/media-libs/libxspf/libxspf-1.2.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils
+EAPI=6
+
+inherit xdg-utils
DESCRIPTION="Playlist handling library"
HOMEPAGE="http://libspiff.sourceforge.net/"
@@ -11,38 +12,39 @@ SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
LICENSE="BSD LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="doc static-libs test"
+IUSE="static-libs test"
-RDEPEND=">=dev-libs/expat-2
+RDEPEND="
+ >=dev-libs/expat-2
>=dev-libs/uriparser-0.7.5"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? (
- >=app-doc/doxygen-1.5.8
- media-gfx/graphviz
- dev-qt/qthelp:4
- )
test? ( >=dev-util/cpptest-1.1 )"
-DOCS="AUTHORS ChangeLog NEWS README THANKS"
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ default
+ xdg_environment_reset
+
+ # do not install missing files
+ sed -e 's/gif,//' -i doc/Makefile* \
+ -i bindings/c/doc/Makefile* || die "sed failed"
}
src_configure() {
- export XDG_CONFIG_HOME="${T}" #398881#c2
-
econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-doc \
$(use_enable static-libs static) \
- $(use_enable test) \
- $(use_enable doc)
+ $(use_enable test)
}
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
}