summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan.mohammadpour@umontreal.ca>2022-10-17 11:18:07 +0200
committerDavid Seifert <soap@gentoo.org>2022-10-17 11:18:07 +0200
commitad302cba45f4f5dafbba03e432bfa08367ab1767 (patch)
tree2a5b6d496872d24fc3c7fbab1f7b287e9d7f6590
parentapp-emulation/wine-staging: sync live (diff)
downloadgentoo-ad302cba45f4f5dafbba03e432bfa08367ab1767.tar.gz
gentoo-ad302cba45f4f5dafbba03e432bfa08367ab1767.tar.bz2
gentoo-ad302cba45f4f5dafbba03e432bfa08367ab1767.zip
dev-libs/cudnn: add 8.6.0.163
Closes: https://github.com/gentoo/gentoo/pull/27816 Signed-off-by: Sobhan Mohammadpour <sobhan.mohammadpour@umontreal.ca> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/cudnn/Manifest1
-rw-r--r--dev-libs/cudnn/cudnn-8.6.0.163.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/cudnn/Manifest b/dev-libs/cudnn/Manifest
index 282a777ebb27..0dffe58e8c34 100644
--- a/dev-libs/cudnn/Manifest
+++ b/dev-libs/cudnn/Manifest
@@ -1,3 +1,4 @@
DIST cudnn-linux-x86_64-8.3.1.22_cuda11.5-archive.tar.xz 856769204 BLAKE2B 375021592470b1f17d7a69701f1ac3289ceb8ddbbdacf577fa51abfdad263102d3c6cedb24ac829c49e033300532e77b6064835a8ae1e05377e375f4320c9a15 SHA512 815ef678b7510e014181f3bf782e627771e8d00d218b34f2af11436b8a49331400269f98448854353c12721468365b71a8483eb7631777f0d628982e81942a8b
DIST cudnn-linux-x86_64-8.3.2.44_cuda11.5-archive.tar.xz 857894928 BLAKE2B 7f0f4fe4d8ccd2e7385d5c4535f4543b3d8e80f65caa5a4d5fdaa1b386a76fe16d8d9e32745a098954eda8d0b803af6146c1ffc5b46c838ea0ccecd5923984cf SHA512 4f2159e48685613b436adb3995aa80cf6d5b395c146059ccc15ef2f5f7e47c94bfeebd14b09d8832f7df76d2379829aa32edb7b69852e17a8e7036084265ed39
DIST cudnn-linux-x86_64-8.4.1.50_cuda11.6-archive.tar.xz 850711772 BLAKE2B 47e03d7a25f92cb2e2793e7d13b6182da62329a7868a785ca2224bccfc97960721fba26e1e8a933e8d449085e895c129871bb2fd7c690265d01ad10564a1b939 SHA512 bf2069edf5c73db325d4ef27e3976169b9bd32afc49f012bd1e6f7d9bd374179dd9312538e7be7b0f8d5da0f2edd79b6788868e183f00f8b99fda185302d07c3
+DIST cudnn-linux-x86_64-8.6.0.163_cuda11-archive.tar.xz 864470696 BLAKE2B e842f5861653f2bc8509cc654e5c40436556786610fbc4ab40781cd8246d5bc94e3e3fae0b0933c947941dc0b6eacbd44d6a54702566e5aefcff56df3f884149 SHA512 15d86b8884bf7b48b4aa1022ea26f0965dd50a9911ca1e6fb89e5266181e662547ba077b2e2e9f19bd135aef9d21fb0a3348b97c7fac9059bb241657046d6d60
diff --git a/dev-libs/cudnn/cudnn-8.6.0.163.ebuild b/dev-libs/cudnn/cudnn-8.6.0.163.ebuild
new file mode 100644
index 000000000000..318215eb1de8
--- /dev/null
+++ b/dev-libs/cudnn/cudnn-8.6.0.163.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BASE_V="$(ver_cut 0-3)"
+# supports 11.x but URL has a specific version number
+CUDA_MA="11"
+CUDA_MI="8"
+CUDA_V="${CUDA_MA}.${CUDA_MI}"
+
+DESCRIPTION="NVIDIA Accelerated Deep Learning on GPU library"
+HOMEPAGE="https://developer.nvidia.com/cudnn"
+SRC_URI="https://developer.download.nvidia.com/compute/redist/cudnn/v${BASE_V}/local_installers/${CUDA_V}/cudnn-linux-x86_64-${PV}_cuda${CUDA_MA}-archive.tar.xz"
+S="${WORKDIR}/cudnn-linux-x86_64-${PV}_cuda${CUDA_MA}-archive"
+
+LICENSE="NVIDIA-cuDNN"
+SLOT="0/8"
+KEYWORDS="~amd64 ~amd64-linux"
+RESTRICT="mirror"
+
+RDEPEND="=dev-util/nvidia-cuda-toolkit-11*"
+
+QA_PREBUILT="/opt/cuda/targets/x86_64-linux/lib/*"
+
+src_install() {
+ insinto /opt/cuda/targets/x86_64-linux
+ doins -r include lib
+}