summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2021-06-18 12:35:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-18 17:47:02 +0300
commitad567322e26c6847d93300f9fea3e180898ee101 (patch)
treea0140c013cde9dfeba2eabb3699b44e5063b157a
parentmedia-gfx/graphicsmagick: drop IUSE=cxx (always on) (diff)
downloadgentoo-ad567322e26c6847d93300f9fea3e180898ee101.tar.gz
gentoo-ad567322e26c6847d93300f9fea3e180898ee101.tar.bz2
gentoo-ad567322e26c6847d93300f9fea3e180898ee101.zip
app-text/nfoview: enable pytest
use distutils_enable_tests pytest Closes: https://bugs.gentoo.org/796287 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/nfoview/nfoview-1.28.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-text/nfoview/nfoview-1.28.ebuild b/app-text/nfoview/nfoview-1.28.ebuild
index c619ae9688c5..2b8c11296e62 100644
--- a/app-text/nfoview/nfoview-1.28.ebuild
+++ b/app-text/nfoview/nfoview-1.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1 xdg
+inherit distutils-r1 virtualx xdg
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
@@ -27,3 +27,13 @@ BDEPEND="${PYTHON_DEPS}
DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
media-fonts/cascadia-code"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ --deselect 'nfoview/test/test_util.py::TestModule::test_show_uri__unix'
+ --deselect 'nfoview/test/test_util.py::TestModule::test_show_uri__windows'
+ )
+ virtx epytest "${deselect[@]}"
+}