summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-21 10:12:58 +0200
committerAmy Liffey <amynka@gentoo.org>2017-09-21 16:58:31 +0200
commitad60b775832549c239bd32a3e02c7c46cca27515 (patch)
tree2a7b8d2ec894d6680901826f84d3fd706bd23145
parentwww-apps/kibana-bin: bump to 5.6.1 (diff)
downloadgentoo-ad60b775832549c239bd32a3e02c7c46cca27515.tar.gz
gentoo-ad60b775832549c239bd32a3e02c7c46cca27515.tar.bz2
gentoo-ad60b775832549c239bd32a3e02c7c46cca27515.zip
app-admin/filebeat: bump to 5.6.1
Closes:#5746 Package-Manager: Portage-2.3.10, Repoman-2.3.2
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-5.6.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 72139064c2a4..77e4401adc46 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -1 +1,2 @@
DIST filebeat-5.5.2.tar.gz 18075191 SHA256 39e792324a35fe84ef9a63cd5324252bc71d1c665188e8d597e12ca170cfde7a SHA512 ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48 WHIRLPOOL 46d182bd339abd26f3c4cf3f8d3a716180fc00147458f571eec34aefcaa67d9e88a561988e37c47083528024e4e0559b255c7a17efa43e0e4b21b653a575f7fd
+DIST filebeat-5.6.1.tar.gz 18142175 SHA256 3534ef7a3833ae85aef53a12580520b5d85feaa1408289ea37a6ebff5a2fda0a SHA512 842fd28012455ddacffb66db719e1df6fe987c844899d34428d65bca2ec4e1b49a801a976f546b4380da077426250109c5b1c84188a44c14c98f054165b27123 WHIRLPOOL 1d11e08572e51c526cd0443b3fe3ce691dbcd8bc5463a531d89d2685df157f61e28ca645c37f273e7f5b7c69984f5152de310a140567cd757b70a68d0bc578aa
diff --git a/app-admin/filebeat/filebeat-5.6.1.ebuild b/app-admin/filebeat/filebeat-5.6.1.ebuild
new file mode 100644
index 000000000000..451e2191c7ae
--- /dev/null
+++ b/app-admin/filebeat/filebeat-5.6.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-lang/go-1.8.3"
+RDEPEND="!app-admin/filebeat-bin"
+
+ELASTIC="${WORKDIR}/src/github.com/elastic"
+BEATS="${ELASTIC}/beats"
+S="${BEATS}"
+
+src_unpack() {
+ mkdir -p "${ELASTIC}" || die
+ unpack ${P}.tar.gz
+ mv beats-${PV} "${BEATS}" || die
+}
+
+src_compile() {
+ cd ${BEATS}/filebeat || die
+ GOPATH="${WORKDIR}" emake
+}
+
+src_test() {
+ cd ${BEATS}/filebeat || die
+ GOPATH="${WORKDIR}" emake check
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ insinto "/usr/share/doc/${PF}/examples"
+ doins ${PN}/{filebeat.yml,filebeat.full.yml}
+
+ insinto "/etc/${PN}"
+ doins ${PN}/{filebeat.template.json,filebeat.template-es2x.json,filebeat.template-es6x.json}
+
+ exeinto "/usr/share/${PN}"
+ doexe libbeat/scripts/migrate_beat_config_1_x_to_5_0.py
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/5.0/upgrading.html"
+ elog ""
+ elog "The migration script:"
+ elog "${EROOT%/}/usr/share/filebeat/migrate_beat_config_1_x_to_5_0.py"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}