summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2022-08-23 09:30:18 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-08-24 11:26:11 +0200
commitad7bd93acc2e502af05886af309ab2fe7e5f0093 (patch)
treebfc7c2628dddf52d06c44c61afb9adfd7cd926d1
parentdev-qt/qtquickcontrols2: Fix missing vertical scrollbars (diff)
downloadgentoo-ad7bd93a.tar.gz
gentoo-ad7bd93a.tar.bz2
gentoo-ad7bd93a.zip
net-dns/knot: Bump to 3.2.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/26997 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-3.2.0.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 43317be44a48..2608747b2b6b 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -2,3 +2,4 @@ DIST knot-3.1.5.tar.xz 1414500 BLAKE2B c05fcd9e99d4c7dba03ad9fd9a1131ca4c2556d49
DIST knot-3.1.7.tar.xz 1418944 BLAKE2B d0e5c999c1b4bca89b86ad956dd91643f795fcba94757e34c44e3e6b925030c332da9cb0bfd72d6ae0f32b3016a8c50d821cfcc513268682dd6b5715714d9047 SHA512 4b6982e8b44addbc77f42d0a1c435dd257cc8a8f112677c371d16063ee8e769b646a6425d54ef338cd21555f276d8d6f4faad2da2f24bf92437ce4af9ff1fb44
DIST knot-3.1.8.tar.xz 1439912 BLAKE2B bcc089d547a7cad8150e93d70da036273a60b0e740df9693bc38813c3d7ed1968b8f97ce4d32c2359ba509fdfcd8403e73eed1f0107d470e6cd4ba4e7012f96d SHA512 af72cbcc5b511dad148e7ce990819df00bdf99c110b44b3b521eddd8690a6ebd4c76c24e63d843956971d5f158bbfa851804616630d34f3a0ec06888c78ecf2c
DIST knot-3.1.9.tar.xz 1441408 BLAKE2B 383829107bef6b35cbef3c531bc91050e7742ca930bf6645c25cab04203ee360837808c3b5342089ce9ba9ee704290ab95b2f76172577d251c6a9c18796245a0 SHA512 e4ba1c006edcde2dc820e74c39df7a8b8983dfb2d8b8845ac759c6c67dfaabc5aae38282995ed92879a683665c0c179502858631c89ad53c2738f79df951eef7
+DIST knot-3.2.0.tar.xz 1665720 BLAKE2B 851f8278e2936459ca8bf4f06332d6a49e89152e634aaa94235d180c91a073c648797f8e42e371f563bbeb708289fdf3839f66508fbd41b7e045efbbe5d72374 SHA512 e007d633f1debb559d47a7646b055dc970502be11a1849063da3e3d28355f77e6cba41e34f06726bc5945e4e2ba3ecb84a4b39813a8079514d3bf584d7d565a2
diff --git a/net-dns/knot/knot-3.2.0.ebuild b/net-dns/knot/knot-3.2.0.ebuild
new file mode 100644
index 000000000000..77cbe56a39d2
--- /dev/null
+++ b/net-dns/knot/knot-3.2.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps doh +fastparser idn +libidn2 systemd +utils xdp ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb:=
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb:=
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ doh? ( net-libs/nghttp2:= )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+ xdp? (
+ dev-libs/libbpf:=
+ net-libs/libmnl:=
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ $(use_enable xdp)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ $(use_with doh libnghttp2)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ if use riscv; then
+ append-libs -latomic
+ fi
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+
+ keepdir /var/lib/knot
+}