summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-09-13 14:06:53 +0200
committerAaron Bauman <bman@gentoo.org>2020-11-11 12:03:12 -0500
commitad89812116856f42661b9eb30569364ddbf1bb47 (patch)
treea9bcadc6942affee6c315bb900e52080050ae481
parentsys-kernel/gentoo-sources: Linux version bumps (diff)
downloadgentoo-ad89812116856f42661b9eb30569364ddbf1bb47.tar.gz
gentoo-ad89812116856f42661b9eb30569364ddbf1bb47.tar.bz2
gentoo-ad89812116856f42661b9eb30569364ddbf1bb47.zip
sys-auth/seatd: New package
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/files/seatd.initd4
-rw-r--r--sys-auth/seatd/metadata.xml12
-rw-r--r--sys-auth/seatd/seatd-0.4.0.ebuild47
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild47
5 files changed, 111 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
new file mode 100644
index 000000000000..031dd4e115ec
--- /dev/null
+++ b/sys-auth/seatd/Manifest
@@ -0,0 +1 @@
+DIST seatd-0.4.0.tar.gz 34242 BLAKE2B 295ee18736b5f7e1b06013d00514321aad5fb09c285690cfbd78833a9efbfeb2cfaef69c075fb096fedaac42ff249ee1a43593dbd03132770c1be293ffe7ddc1 SHA512 498ab4040c19ff90842bf82f580ba24c2c98e0aded7ba636dcffc80f6bfd8869eec3e87e784455b66e2b69786b2fc6e7315b2867effa825440759d58e391378c
diff --git a/sys-auth/seatd/files/seatd.initd b/sys-auth/seatd/files/seatd.initd
new file mode 100644
index 000000000000..f95a52f15632
--- /dev/null
+++ b/sys-auth/seatd/files/seatd.initd
@@ -0,0 +1,4 @@
+#!/sbin/openrc-run
+supervisor=supervise-daemon
+command="seatd"
+command_args="-g video"
diff --git a/sys-auth/seatd/metadata.xml b/sys-auth/seatd/metadata.xml
new file mode 100644
index 000000000000..fa389813e2dd
--- /dev/null
+++ b/sys-auth/seatd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>contact@hacktivis.me</email>
+ <name>Haelwenn (lanodan) Monnier</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/seatd/seatd-0.4.0.ebuild b/sys-auth/seatd/seatd-0.4.0.ebuild
new file mode 100644
index 000000000000..53deb0005335
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/seatd.initd" seatd
+}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
new file mode 100644
index 000000000000..53deb0005335
--- /dev/null
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/seatd.initd" seatd
+}