summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-15 19:44:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:21:30 +0200
commitad8cb210b7d2fc9b4222b1db94ed56fcb8438b7e (patch)
tree776f796f6aba373089976ef91824530a73dfe9f3
parentdev-python/zope-deprecation: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-ad8cb210.tar.gz
gentoo-ad8cb210.tar.bz2
gentoo-ad8cb210.zip
dev-python/weasyprint: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748990 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/weasyprint/weasyprint-51.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/weasyprint/weasyprint-51.ebuild b/dev-python/weasyprint/weasyprint-51.ebuild
index fdcc64deeca7..dde41858dcdb 100644
--- a/dev-python/weasyprint/weasyprint-51.ebuild
+++ b/dev-python/weasyprint/weasyprint-51.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} )
inherit distutils-r1
@@ -34,7 +35,7 @@ RDEPEND="
x11-libs/pango:0/0
"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]