summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:46:43 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:52 +0100
commitad948a6059b1dbc9c89d040ac9cd957ac5ea7953 (patch)
treeac521a721bf79dd8ff56c78bccde45dc680d2a5d
parentx11-misc/mugshot: drop 0.4.3 (diff)
downloadgentoo-ad948a6059b1dbc9c89d040ac9cd957ac5ea7953.tar.gz
gentoo-ad948a6059b1dbc9c89d040ac9cd957ac5ea7953.tar.bz2
gentoo-ad948a6059b1dbc9c89d040ac9cd957ac5ea7953.zip
x11-misc/xflux: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--x11-misc/xflux/xflux-20130927-r2.ebuild31
-rw-r--r--x11-misc/xflux/xflux-20170103-r1.ebuild28
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/xflux/xflux-20130927-r2.ebuild b/x11-misc/xflux/xflux-20130927-r2.ebuild
new file mode 100644
index 000000000000..f51b9bab56ba
--- /dev/null
+++ b/x11-misc/xflux/xflux-20130927-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Makes the color of your computer's display adapt to the time of the day"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="
+ amd64? ( https://justgetflux.com/linux/${PN}64.tgz -> ${PN}64-${PV}.tar.gz )
+ x86? ( https://justgetflux.com/linux/${PN}-pre.tgz -> ${P}.tar.gz )
+"
+S="${WORKDIR}"
+
+KEYWORDS="-* amd64 x86"
+LICENSE="f.lux"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+"
+
+QA_PREBUILT="usr/bin/xflux"
+
+src_install() {
+ dobin xflux
+}
diff --git a/x11-misc/xflux/xflux-20170103-r1.ebuild b/x11-misc/xflux/xflux-20170103-r1.ebuild
new file mode 100644
index 000000000000..c3e0c5cab0ea
--- /dev/null
+++ b/x11-misc/xflux/xflux-20170103-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Makes the color of your computer's display adapt to the time of the day"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="https://justgetflux.com/linux/${PN}12.tgz -> ${PN}12-${PV}.tar.gz"
+S="${WORKDIR}"
+
+KEYWORDS="-* amd64"
+LICENSE="f.lux"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+"
+
+QA_PREBUILT="usr/bin/xflux"
+
+src_install() {
+ newbin xflux12 xflux
+}