summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-02 12:44:42 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-02 13:04:41 +0200
commitadb3bc8e64f8afe51ae31d8070b98f2a88a243ee (patch)
tree7d03d254694354924d8bd37d8a92f55b6a055d1e
parentsci-visualization/visit: remove unused patches (diff)
downloadgentoo-adb3bc8e.tar.gz
gentoo-adb3bc8e.tar.bz2
gentoo-adb3bc8e.zip
sci-biology/pysam: Bump to 0.12
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/pysam-0.12.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 24afdea8b623..b2e7af85717f 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1 +1,2 @@
+DIST pysam-0.12.tar.gz 2537142 SHA256 33922cb3277ed9a63457c1b6a9dcad2774a217ababcc97a854435be87ba80488 SHA512 095a47cd7258ef093a172445c425f382996da886e44e1beb81ecdec2325024e099d14bee6fcd928c4449099f51ad92b6d7ceb464815c463ab4478f162a40f21e WHIRLPOOL 2331e24d817cd3e7372df8e115498456e685ac426796b29c6d5a28edbaab2321f7efc9db0f14a000750fcd9e30391c02b81e439a07596813bdf7fc6c6e1a3ae3
DIST pysam-0.9.0.tar.gz 2701721 SHA256 dd4946c8efa6786a754e2b50c6027dd03aa82c8ee6c2be3b4e51384da80b4c7c SHA512 9189ef2b56df0f5e2c84586c0c2b2cd46a77dbedd3aa6fd25ddcc4a93320038bead073206fff528ae9775f153c875838726dd0af8e4c7bf4e0c6063145e2bc06 WHIRLPOOL 6c7d459057fed3961e983b3e8563e10a47cb87f5da2fb99ca893eff9e19a8b9e4c27b5d82a978a611d615eba8052fbe3e36498ea461e03521a075d9aee8da463
diff --git a/sci-biology/pysam/pysam-0.12.ebuild b/sci-biology/pysam/pysam-0.12.ebuild
new file mode 100644
index 000000000000..e181e06ac9bc
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.python.org/pypi/pysam"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.5*:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ export HTSLIB_INCLUDE_DIR="${EPREFIX}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${EPREFIX}"/usr/$(get_libdir)
+ export HTSLIB_CONFIGURE_OPTIONS="--disable-libcurl"
+
+ # prevent setup.py from adding RPATHs
+ sed -e "/ext\.extra_link_args += \['-Wl,-rpath,\$ORIGIN'\]/d" \
+ -i cy_build.py || die
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ # TODO
+ # empty compile, as the build system runs the whole build again in install
+ :
+}