summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-13 21:01:36 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-13 21:01:36 +0100
commitadb3e22a996e1fceb131e4423eab933e76ce39d5 (patch)
treeb45a642a706d32c475ae9c0fbbd7f288f5f3a26a
parentx11-libs/libXaw3d: Port to EAPI 7 (diff)
downloadgentoo-adb3e22a996e1fceb131e4423eab933e76ce39d5.tar.gz
gentoo-adb3e22a996e1fceb131e4423eab933e76ce39d5.tar.bz2
gentoo-adb3e22a996e1fceb131e4423eab933e76ce39d5.zip
x11-libs/libXaw3dXft: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild
index 705b95f8aae6..3523c3b1a0bb 100644
--- a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2d.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="Xaw3dXft library"
HOMEPAGE="https://sourceforge.net/projects/sf-xpaint"
@@ -12,24 +12,25 @@ SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
KEYWORDS="amd64 x86"
IUSE="unicode xpm"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXft
x11-libs/libXmu
x11-libs/libXt
xpm? ( x11-libs/libXpm )"
DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc
x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable unicode internationalization)
$(usex xpm "--enable-multiplane-bitmaps" "")
--enable-arrow-scrollbars
--enable-gray-stipples
)
-
- xorg-2_pkg_setup
+ xorg-3_src_configure
}