summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 13:19:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 13:32:03 +0200
commitadec4af1206da37c3c8c7bb325796504863776f2 (patch)
tree0a3a500a6445d78e31472a6273aef573149ae9aa
parentdev-python/keyrings-alt: Remove old (diff)
downloadgentoo-adec4af1206da37c3c8c7bb325796504863776f2.tar.gz
gentoo-adec4af1206da37c3c8c7bb325796504863776f2.tar.bz2
gentoo-adec4af1206da37c3c8c7bb325796504863776f2.zip
dev-python/klein: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/klein/Manifest1
-rw-r--r--dev-python/klein/files/klein-21.8.0-test_resource.patch28
-rw-r--r--dev-python/klein/klein-21.8.0.ebuild46
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/klein/Manifest b/dev-python/klein/Manifest
index 501170634d41..f3d4c7ef9d5a 100644
--- a/dev-python/klein/Manifest
+++ b/dev-python/klein/Manifest
@@ -1,2 +1 @@
-DIST klein-21.8.0.tar.gz 100578 BLAKE2B ea2535e93affebe822ff086eb5749481edf7811340a35b11319b7c23b23d3877f6208ac1ef6cc7a4bb9eedd33d087820304f2ee71695413d72308e83c47aa2ee SHA512 cce28865e172effb6044f73c1841875fa5eb55daf20dcea482d0764604ab826ca5063a4679165bb253953d54428a42c2082022fd273e2a1083aefa595a563ccd
DIST klein-23.5.0.tar.gz 100691 BLAKE2B 913f48d975ef94787da910f217e687046e6d60273aac455eecae89378742cb7533ff5ab0a8ad868d5b363f27af1d0ee68f3b17a16b51482b5e4c015e7a779b53 SHA512 10d7bb1a5aabc035aa69a0f9c25516ee9b6043f442b35b31f5687c249370e4674c4488a9531ff4bc06ea40574fd9a7974343899de3d5b3895f28a2feb70ae543
diff --git a/dev-python/klein/files/klein-21.8.0-test_resource.patch b/dev-python/klein/files/klein-21.8.0-test_resource.patch
deleted file mode 100644
index c9779c46ac17..000000000000
--- a/dev-python/klein/files/klein-21.8.0-test_resource.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://github.com/twisted/klein/commit/bce8b85036a6d185b9e8aab037c805f81354544c
-
-From bce8b85036a6d185b9e8aab037c805f81354544c Mon Sep 17 00:00:00 2001
-From: Glyph <glyph@twistedmatrix.com>
-Date: Tue, 31 May 2022 17:44:13 -0700
-Subject: [PATCH] testing exact content-length is way too strict
-
---- a/src/klein/test/test_resource.py
-+++ b/src/klein/test/test_resource.py
-@@ -2,7 +2,7 @@
- from io import BytesIO
- from types import MappingProxyType
- from typing import Any, Callable, List, Mapping, Optional, Sequence, cast
--from unittest.mock import Mock, call
-+from unittest.mock import ANY, Mock, call
- from urllib.parse import parse_qs
-
- from werkzeug.exceptions import NotFound
-@@ -642,7 +642,7 @@ def foo(request: IRequest) -> KleinRenderable:
- request.setHeader.assert_has_calls(
- [
- call(b"Content-Type", b"text/html; charset=utf-8"),
-- call(b"Content-Length", b"258"),
-+ call(b"Content-Length", ANY),
- call(b"Location", b"http://localhost:8080/foo/"),
- ]
- )
-
diff --git a/dev-python/klein/klein-21.8.0.ebuild b/dev-python/klein/klein-21.8.0.ebuild
deleted file mode 100644
index 9444fbdbe265..000000000000
--- a/dev-python/klein/klein-21.8.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 pypi
-
-DESCRIPTION="micro-framework for developing production-ready web services with Python"
-HOMEPAGE="https://pypi.org/project/klein/ https://github.com/twisted/klein/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/hyperlink[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/tubes[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.6[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/treq[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-test_resource.patch
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # known test fail: https://github.com/twisted/klein/issues/339
-# sed -e 's/big world/big+world/' \
-# -e 's/4321)]/4321.0)]/' \
-# -e 's/not a number/not+a+number/' \
-# -i src/klein/test/test_form.py || die
-
- distutils-r1_python_prepare_all
-}