summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-07-06 13:36:42 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-07-06 13:36:42 +0200
commitadfec6298b688d7aa7c59da457eecdd99e05d856 (patch)
tree789e31c2e918ac5473a717dd73a3a3d98102c1d2
parentdev-python/pymetar: clean up old versions (diff)
downloadgentoo-adfec6298b688d7aa7c59da457eecdd99e05d856.tar.gz
gentoo-adfec6298b688d7aa7c59da457eecdd99e05d856.tar.bz2
gentoo-adfec6298b688d7aa7c59da457eecdd99e05d856.zip
dev-python/pymetar: Add v1.3, fix doc/extra files
Upstream setup.py used to install a man page, and two doc files using `data_files`. This approach worked in the past but is not really supported. V1.3 does no longer install those files (it is not really portable anyway). So instead, we do it in the ebuild. Closes: https://bugs.gentoo.org/800737 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
-rw-r--r--dev-python/pymetar/Manifest1
-rw-r--r--dev-python/pymetar/pymetar-1.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pymetar/Manifest b/dev-python/pymetar/Manifest
index 3eb3cf3aa13e..e313550c5636 100644
--- a/dev-python/pymetar/Manifest
+++ b/dev-python/pymetar/Manifest
@@ -1 +1,2 @@
DIST pymetar-1.2.tar.gz 3163447 BLAKE2B be3e06efa007db46bd90e944ce60d24389f6b8685fcbb66803aca9b46b62cbb23b27e4ef7b2dc47080b6e6c9366acd3ecf13d02ef47ca50705a7631006482002 SHA512 4f19e99f56497b59ca31620a41beb7fd896b4503ed3edd34bafc8e9158895a238cc721e4161c2940abb49b34b1a7cbeb3d97952c4b19361d74a8b3ca56ea2fe7
+DIST pymetar-1.3.tar.gz 3162924 BLAKE2B 65327935cfcd78b56855fc0dd24cabeff315e75a9262ca586df0ad20e246ff1b7781a806e62e1f51e250761d26afa14f6fb911cc1994047001f9dc20dedccfe6 SHA512 255086913de89915afc0cd9284bd1036ced9a0d02493d3eb8e2e53bcff7f14d7b9d453f3f687fe32103ce6c0587ac604b671f271013e27ea09a5062f7a7a79af
diff --git a/dev-python/pymetar/pymetar-1.3.ebuild b/dev-python/pymetar/pymetar-1.3.ebuild
new file mode 100644
index 000000000000..51894f79ee8d
--- /dev/null
+++ b/dev-python/pymetar/pymetar-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Downloads and decodes to the weather report for a given station ID"
+HOMEPAGE="https://www.schwarzvogel.de/software/pymetar/"
+SRC_URI="https://www.schwarzvogel.de/pkgs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dodoc "${S}/README.md"
+ dodoc "${S}/THANKS"
+ doman "${S}/pymetar.1"
+ python_foreach_impl distutils-r1_python_install
+}