summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-05 09:10:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-05 10:27:19 +0200
commitae08f58b729e717f4edee81787849f5578dd606e (patch)
tree0e364762c62a8aa2f5895500ccdd5978e78ecfae
parentdev-python/ddt: Bump to 1.4.4 (diff)
downloadgentoo-ae08f58b.tar.gz
gentoo-ae08f58b.tar.bz2
gentoo-ae08f58b.zip
dev-python/jupyter_server: Bump to 1.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_server/Manifest1
-rw-r--r--dev-python/jupyter_server/jupyter_server-1.11.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/jupyter_server/Manifest b/dev-python/jupyter_server/Manifest
index 8b3dbe97a79f..90b1554404e8 100644
--- a/dev-python/jupyter_server/Manifest
+++ b/dev-python/jupyter_server/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_server-1.11.0.tar.gz 419795 BLAKE2B 992bcadfd10cebc9d2c14ecc1489af91c161edc4fd8386d4b3e30c087737b3de723b5fa8d7f2cbb537e6f20568e6ed15f110e70781bc90cdc699fe6374ed3277 SHA512 9c8afb86af3669270e3103485500b635eb2dda35d731fb1adf3db997bb76ac61a769858525aacc6fb32ede7a299f0fc21991d0b64d009f506af232733b47b141
+DIST jupyter_server-1.11.1.tar.gz 420035 BLAKE2B 0676b0e126752ebeaa45e2325c34fe787756265f5ad35e356660485e5e7fd98a9ecaa029badf4c45815f25425e5a8a44133b6595698dca212f871b898c6ef76c SHA512 537bb9dbacabe396761a17be3280ecc0d28d63116a72386a7ff69bd8467f38909b7c2491eeb1f6b8bb7618b7fe661cd583d9efb8597ecbe88941c35096e0b1a8
DIST jupyter_server-1.8.0.tar.gz 408312 BLAKE2B db385085a1a660d707cc84570627e754dc19105af5157bc42e259822c9e98364ab77a9a16403d9b43757a6e175102632e83dd21466dff3487101771b51fdeb5f SHA512 3c4c9d64b7f0e26a79b38bc95106e062f1c363a13fc3b32c3897bbb15a7d91a64e46926b35c07f8c5bd440f55e3d01ec57c54c8b244969b6af7f7e18347030cd
diff --git a/dev-python/jupyter_server/jupyter_server-1.11.1.ebuild b/dev-python/jupyter_server/jupyter_server-1.11.1.ebuild
new file mode 100644
index 000000000000..8d81f28043df
--- /dev/null
+++ b/dev-python/jupyter_server/jupyter_server-1.11.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-6.1.1[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ )"
+
+# TODO: Package 'myst_parser'
+# distutils_enable_sphinx docs/source
+# dev-python/pydata-sphinx-theme
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv jupyter_server/conftest.py . || die
+
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ sed -i \
+ -e 's:est_terminal_create_with_cwd:_&:' \
+ -e 's:test_culling:_&:' \
+ jupyter_server/tests/test_terminal.py || die
+
+ distutils-r1_python_prepare_all
+}