summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-21 02:23:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-21 04:12:19 +0200
commitae1c27a32c486283b4abaafa259e4870d97df630 (patch)
tree674433e7c3ce28a941feba69a75b85aade54ada6
parentnet-fs/autofs: fix musl build error (diff)
downloadgentoo-ae1c27a32c486283b4abaafa259e4870d97df630.tar.gz
gentoo-ae1c27a32c486283b4abaafa259e4870d97df630.tar.bz2
gentoo-ae1c27a32c486283b4abaafa259e4870d97df630.zip
media-video/pipewire: bump to v0.3.28
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--media-video/pipewire/Manifest1
-rw-r--r--media-video/pipewire/pipewire-0.3.28.ebuild285
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild2
3 files changed, 287 insertions, 1 deletions
diff --git a/media-video/pipewire/Manifest b/media-video/pipewire/Manifest
index f9aa987bfa95..3ecd570692fb 100644
--- a/media-video/pipewire/Manifest
+++ b/media-video/pipewire/Manifest
@@ -2,3 +2,4 @@ DIST pipewire-0.3.22.tar.gz 1263844 BLAKE2B 3fb90c0b1c17ed108e8c390873f5c4527e1f
DIST pipewire-0.3.25.tar.gz 1351257 BLAKE2B 3c4d6d98e3255df8baf50eb548bcf77b5c027a50f6acedd83cd63481ed5b642c174589f34314f150b07116cea8a3458c3f8b770df4081585d7f75cc8dde4decd SHA512 0f84be21bfcd70f25900c53a8ce399c29ce2d4d10f8b56e5103603cf0c80673aab0b16492e55b42985283adf46343cdca01626225db85a2263f06c309f68f2d7
DIST pipewire-0.3.26.tar.gz 1447673 BLAKE2B 67feb1288fcdc9ac5578b97ab2567b46a7431921291584bc9db2c2e60db074c3a61c3af9859d3b2f9044cfba6c15e9bfde9edc001b753f8fc47965eb55d751c8 SHA512 d771956a42801a6e07fac48a175363eb4107a9fba13d649ff5c2cdc40044c84a61bf56050783507f6dd8efae8c59a2be07ec67433827335ae60f8116c4a4e178
DIST pipewire-0.3.27.tar.gz 1459913 BLAKE2B b6db73de85c41932b630e62b3dcc589529ae5457cae6731a8ec5db50f20b541e7e9596976a368c4bb654b1443071c53f8fe4a9ddfc1ee8a0ecc04d69b683456a SHA512 a2df1df8e43846b91fbeedeb1cda9c73b970ac9de58d8b4e97ada54ee74a8f26a168504289c7392c94cc7ea54aa01ada4791c66a5d3159a2bc980df633f6bcfe
+DIST pipewire-0.3.28.tar.gz 1474219 BLAKE2B d20b39c8ed49cd44f2109aab6453aac547ff66dc2ef4a52fb71fea27eb07920efc58498e5ddd82e9f6d86981185e37313748d9157c9a09a3ae1e8ae48d5d45d6 SHA512 f2ed23609c6a45fb80f54caabaa304ba4f318c905a28350c89c65f179a95cc2022f1acbb0c2ec558baf4dc6bcc5623b8daa6678d52cdb9179a88c67b6c1fe0ff
diff --git a/media-video/pipewire/pipewire-0.3.28.ebuild b/media-video/pipewire/pipewire-0.3.28.ebuild
new file mode 100644
index 000000000000..5504603123f0
--- /dev/null
+++ b/media-video/pipewire/pipewire-0.3.28.ebuild
@@ -0,0 +1,285 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit meson optfeature udev multilib-minimal
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Multimedia processing graphs"
+HOMEPAGE="https://pipewire.org/"
+
+LICENSE="MIT LGPL-2.1+ GPL-2"
+SLOT="0/0.3"
+IUSE="aac aptx bluetooth doc extra gstreamer jack-client jack-sdk ldac pipewire-alsa systemd test v4l"
+
+# Once replacing system JACK libraries is possible, it's likely that
+# jack-client IUSE will need blocking to avoid users accidentally
+# configuring their systems to send PW sink output to the emulated
+# JACK's sink - doing so is likely to yield no audio, cause a CPU
+# cycles consuming loop (and may even cause GUI crashes)!
+
+REQUIRED_USE="
+ aac? ( bluetooth )
+ aptx? ( bluetooth )
+ jack-sdk? ( !jack-client )
+ ldac? ( bluetooth )
+"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-doc/xmltoman
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+RDEPEND="
+ acct-group/audio
+ media-libs/alsa-lib
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-libs/ncurses[unicode]
+ virtual/libintl[${MULTILIB_USEDEP}]
+ virtual/libudev[${MULTILIB_USEDEP}]
+ bluetooth? (
+ aac? ( media-libs/fdk-aac )
+ aptx? ( media-libs/libopenaptx )
+ ldac? ( media-libs/libldac )
+ media-libs/sbc
+ >=net-wireless/bluez-4.101:=
+ )
+ extra? (
+ >=media-libs/libsndfile-1.0.20
+ )
+ gstreamer? (
+ >=dev-libs/glib-2.32.0:2
+ >=media-libs/gstreamer-1.10.0:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jack-client? ( >=media-sound/jack2-1.9.10:2[dbus] )
+ jack-sdk? (
+ !media-sound/jack-audio-connection-kit
+ !media-sound/jack2
+ )
+ pipewire-alsa? (
+ >=media-libs/alsa-lib-1.1.7[${MULTILIB_USEDEP}]
+ || (
+ media-plugins/alsa-plugins[-pulseaudio]
+ !media-plugins/alsa-plugins
+ )
+ )
+ !pipewire-alsa? ( media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio] )
+ systemd? ( sys-apps/systemd )
+ v4l? ( media-libs/libv4l )
+"
+
+DEPEND="${RDEPEND}"
+
+# Present RDEPEND that are currently always disabled due to the PW
+# code using them being required to be disabled by Gentoo guidelines
+# (i.e. developer binaries not meant for users) and unready code
+# media-video/ffmpeg:=
+# media-libs/libsdl2
+# >=media-libs/vulkan-loader-1.1.69
+#
+# Ditto for DEPEND
+# >=dev-util/vulkan-headers-1.1.69
+
+DOCS=( {README,INSTALL}.md NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
+)
+
+# limitsdfile related code taken from =sys-auth/realtime-base-0.1
+# with changes as necessary.
+limitsdfile=40-${PN}.conf
+
+meson_native_enabled() {
+ if multilib_is_native_abi; then
+ echo "-D${1}=enabled"
+ else
+ echo "-D${1}=disabled"
+ fi
+}
+
+meson_native_feature() {
+ multilib_native_usex "${1}" "-D${2-${1}}=enabled" "-D${2-${1}}=disabled"
+}
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ # This can be applied non-conditionally but would make for a
+ # significantly worse user experience on systemd then.
+ eapply "${FILESDIR}"/${PN}-0.3.25-non-systemd-integration.patch
+ fi
+
+ einfo "Generating ${limitsdfile}"
+ cat > ${limitsdfile} <<- EOF || die
+ # Start of ${limitsdfile} from ${P}
+
+ @audio - memlock 256
+
+ # End of ${limitsdfile} from ${P}
+ EOF
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(meson_native_feature doc docs)
+ $(meson_native_enabled examples) # Disabling this implicitly disables -Dmedia-session
+ $(meson_native_enabled media-session)
+ $(meson_native_enabled man)
+ $(meson_feature test tests)
+ -Dinstalled_tests=disabled # Matches upstream; Gentoo never installs tests
+ $(meson_native_feature gstreamer)
+ $(meson_native_feature gstreamer gstreamer-device-provider)
+ $(meson_native_feature systemd)
+ -Dsystemd-system-service=disabled # Matches upstream
+ $(meson_native_feature systemd systemd-user-service)
+ $(meson_feature pipewire-alsa) # Allows integrating ALSA apps into PW graph
+ -Dspa-plugins=enabled
+ -Dalsa=enabled # Allows using kernel ALSA for sound I/O (-Dmedia-session depends on this)
+ -Daudiomixer=enabled # Matches upstream
+ -Daudioconvert=enabled # Matches upstream
+ $(meson_native_feature bluetooth bluez5)
+ $(meson_native_feature bluetooth bluez5-backend-hsp-native)
+ $(meson_native_feature bluetooth bluez5-backend-hfp-native)
+ $(meson_native_feature bluetooth bluez5-backend-ofono)
+ $(meson_native_feature bluetooth bluez5-backend-hsphfpd)
+ $(meson_native_feature aac bluez5-codec-aac)
+ $(meson_native_feature aptx bluez5-codec-aptx)
+ $(meson_native_feature ldac bluez5-codec-ldac)
+ -Dcontrol=enabled # Matches upstream
+ -Daudiotestsrc=enabled # Matches upstream
+ -Dffmpeg=disabled # Disabled by upstream and no major developments to spa/plugins/ffmpeg/ since May 2020
+ -Dpipewire-jack=enabled # Allows integrating JACK apps into PW graph
+ $(meson_native_feature jack-client jack) # Allows PW to act as a JACK client
+ $(meson_feature jack-sdk jack-devel)
+ $(usex jack-sdk "-Dlibjack-path=${EPREFIX}/usr/$(get_libdir)" '')
+ -Dsupport=enabled # Miscellaneous/common plugins, such as null sink
+ -Devl=disabled # Matches upstream
+ -Dtest=disabled # fakesink and fakesource plugins
+ $(meson_native_feature v4l v4l2)
+ -Dlibcamera=disabled # libcamera is not in Portage tree
+ -Dvideoconvert=enabled # Matches upstream
+ -Dvideotestsrc=enabled # Matches upstream
+ -Dvolume=enabled # Matches upstream
+ -Dvulkan=disabled # Uses pre-compiled Vulkan compute shader to provide a CGI video source (dev thing; disabled by upstream)
+ $(meson_native_feature extra pw-cat)
+ -Dudev=enabled
+ -Dudevrulesdir="$(get_udevdir)/rules.d"
+ -Dsdl2=disabled # Controls SDL2 dependent code (currently only examples when -Dinstalled_tests=enabled which we never install)
+ $(meson_native_feature extra sndfile) # Enables libsndfile dependent code (currently only pw-cat)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ # Our customs DOCS do not exist in multilib source directory
+ DOCS= meson_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc/security/limits.d
+ doins ${limitsdfile}
+
+ if use pipewire-alsa; then
+ dodir /etc/alsa/conf.d
+ # These will break if someone has /etc that is a symbol link to a subfolder! See #724222
+ # And the current dosym8 -r implementation is likely affected by the same issue, too.
+ dosym ../../../usr/share/alsa/alsa.conf.d/50-pipewire.conf /etc/alsa/conf.d/50-pipewire.conf
+ dosym ../../../usr/share/alsa/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/99-pipewire-default.conf
+ fi
+
+ if ! use systemd; then
+ insinto /etc/xdg/autostart
+ newins "${FILESDIR}"/pipewire.desktop pipewire.desktop
+
+ exeinto /usr/libexec
+ newexe "${FILESDIR}"/pipewire-launcher.sh pipewire-launcher
+ fi
+}
+
+pkg_postinst() {
+ elog "It is recommended to raise RLIMIT_MEMLOCK to 256 for users"
+ elog "using PipeWire. Do it either manually or add yourself"
+ elog "to the 'audio' group:"
+ elog
+ elog " usermod -aG audio <youruser>"
+ elog
+
+ if ! use jack-sdk; then
+ elog "JACK emulation is incomplete and not all programs will work. PipeWire's"
+ elog "alternative libraries have been installed to a non-default location."
+ elog "To use them, put pw-jack <application> before every JACK application."
+ elog "When using pw-jack, do not run jackd/jackdbus. However, a virtual/jack"
+ elog "provider is still needed to compile the JACK applications themselves."
+ elog
+ fi
+
+ if use systemd; then
+ elog "To use PipeWire for audio, the user units must be manually enabled:"
+ elog
+ elog " systemctl --user enable pipewire.socket pipewire-pulse.socket"
+ elog
+ elog "When switching from PulseAudio, do not forget to disable PulseAudio:"
+ elog
+ elog " systemctl --user disable pulseaudio.service pulseaudio.socket"
+ elog
+ elog "A reboot is recommended to avoid interferences from still running"
+ elog "PulseAudio daemon."
+ elog
+ elog "Both, new users and those upgrading, need to enable pipewire-media-session:"
+ elog
+ elog " systemctl --user enable pipewire-media-session.service"
+ elog
+ elog "NOTE: This is not required when using PipeWire only for screencasting."
+ elog
+ else
+ elog "This ebuild auto-enables PulseAudio replacement. Because of that, users"
+ elog "are recommended to edit: ${EROOT}/etc/pulse/client.conf and disable "
+ elog "autospawn'ing of the original daemon by setting:"
+ elog
+ elog " autospawn = no"
+ elog
+ elog "Please note that the semicolon (;) must _NOT_ be at the beginning of the line!"
+ elog
+ elog "Alternatively, if replacing PulseAudio daemon is not desired, edit"
+ elog "${EROOT}/etc/pipewire/pipewire.conf by commenting out the relevant"
+ elog "command near the end of the file:"
+ elog
+ elog "#\"/usr/bin/pipewire\" = { args = \"-c pipewire-pulse.conf\" }"
+ elog
+ fi
+
+ elog "For latest tips and tricks, troubleshooting information and documentation"
+ elog "in general, please refer to https://wiki.gentoo.org/wiki/PipeWire"
+ elog
+
+ optfeature_header "The following can be installed for optional runtime features:"
+ optfeature "restricted realtime capabilities vai D-Bus" sys-auth/rtkit
+ # Once hsphfpd lands in tree, both it and ofono will need to be checked for presence here!
+ if use bluetooth; then
+ optfeature "better BT headset support (daemon startup required)" net-misc/ofono
+ #optfeature "an oFono alternative (not packaged)" foo-bar/hsphfpd
+ fi
+}
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index c833b6f88796..5504603123f0 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -16,7 +16,7 @@ fi
DESCRIPTION="Multimedia processing graphs"
HOMEPAGE="https://pipewire.org/"
-LICENSE="LGPL-2.1+"
+LICENSE="MIT LGPL-2.1+ GPL-2"
SLOT="0/0.3"
IUSE="aac aptx bluetooth doc extra gstreamer jack-client jack-sdk ldac pipewire-alsa systemd test v4l"