summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2024-03-12 09:47:00 +0100
committerHanno Böck <hanno@gentoo.org>2024-03-12 09:47:00 +0100
commitae274200f12e7c3ab2e03f7fb6a4535ef30cee78 (patch)
tree882c465cc7c6cc3b543088a8b1e1871f785e0800
parentnet-firewall/iptables: Stabilize 1.8.10 x86, #916092 (diff)
downloadgentoo-ae274200.tar.gz
gentoo-ae274200.tar.bz2
gentoo-ae274200.zip
net-analyzer/snallygaster: support python 3.12
Signed-off-by: Hanno Böck <hanno@gentoo.org>
-rw-r--r--net-analyzer/snallygaster/snallygaster-0.0.12-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/snallygaster/snallygaster-0.0.12-r2.ebuild b/net-analyzer/snallygaster/snallygaster-0.0.12-r2.ebuild
new file mode 100644
index 000000000000..d9c89cabbb3b
--- /dev/null
+++ b/net-analyzer/snallygaster/snallygaster-0.0.12-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Finds file leaks and other security problems on HTTP servers"
+HOMEPAGE="https://github.com/hannob/snallygaster"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/dnspython
+ dev-python/urllib3
+ dev-python/beautifulsoup4"
+RDEPEND="${DEPEND}"
+DOCS=( README.md TESTS.md )
+
+# Only codingstyle and similar tests, require dependencies
+# not packaged in Gentoo
+RESTRICT="test"