summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-18 15:52:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-18 15:53:04 +0200
commitae2f9e5e47433b6a08a03b036d6bfd8461618d2e (patch)
tree3bf5ac2e7a1ee277645853e7129414d377179ebb
parentdev-python/simpleeval: Use PEP517 build, py3.11 (diff)
downloadgentoo-ae2f9e5e47433b6a08a03b036d6bfd8461618d2e.tar.gz
gentoo-ae2f9e5e47433b6a08a03b036d6bfd8461618d2e.tar.bz2
gentoo-ae2f9e5e47433b6a08a03b036d6bfd8461618d2e.zip
dev-python/sphinxcontrib-github-alt: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-github-alt/Manifest2
-rw-r--r--dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r2.ebuild (renamed from dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r1.ebuild)21
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/sphinxcontrib-github-alt/Manifest b/dev-python/sphinxcontrib-github-alt/Manifest
index 4075c8bc8391..512c3e9774e0 100644
--- a/dev-python/sphinxcontrib-github-alt/Manifest
+++ b/dev-python/sphinxcontrib-github-alt/Manifest
@@ -1 +1 @@
-DIST sphinxcontrib-github-alt-1.2.tar.gz 3680 BLAKE2B afd5a20d073e58bcb657fbf100b28fab9d8cda2e1ae7e488dab42e8d4b12e4668185657673a56e9c410aa81cb65dbf4b706740511a8ed9d6c49482ea014c2fc0 SHA512 08f6738206232a5f37446ecac7b804178a57173efee58886623c7d2b43678c8acfd5a7527bacfe7c8f004fd531be9606f24a99c5665b78f97a5676398d2d2857
+DIST sphinxcontrib_github_alt-1.2.gh.tar.gz 3680 BLAKE2B afd5a20d073e58bcb657fbf100b28fab9d8cda2e1ae7e488dab42e8d4b12e4668185657673a56e9c410aa81cb65dbf4b706740511a8ed9d6c49482ea014c2fc0 SHA512 08f6738206232a5f37446ecac7b804178a57173efee58886623c7d2b43678c8acfd5a7527bacfe7c8f004fd531be9606f24a99c5665b78f97a5676398d2d2857
diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r1.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r2.ebuild
index 9fe7b806baf5..6b653bee52cb 100644
--- a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r1.ebuild
+++ b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.2-r2.ebuild
@@ -3,17 +3,22 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
-MY_PN="sphinxcontrib_github_alt"
-
+MY_P=sphinxcontrib_github_alt-${PV}
DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
-HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
-SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+HOMEPAGE="
+ https://github.com/jupyter/sphinxcontrib_github_alt/
+ https://pypi.org/project/sphinxcontrib_github_alt/
+"
+SRC_URI="
+ https://github.com/jupyter/sphinxcontrib_github_alt/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD-2"
SLOT="0"
@@ -23,4 +28,6 @@ RDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
!dev-python/sphinxcontrib_github_alt
"
-BDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"