summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-06-14 19:16:45 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-06-28 13:40:58 +0300
commitae59c31266e4b61d6d78ad3dde1eba6f7ba4b833 (patch)
tree789b0a891b2223397c3fe1bc532731b1cf33cb13
parentmail-filter/libmilter: Set default pthread stack size to 256 KB on musl (diff)
downloadgentoo-ae59c312.tar.gz
gentoo-ae59c312.tar.bz2
gentoo-ae59c312.zip
x11-misc/menumaker: bump to 0.99.12
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-misc/menumaker/Manifest1
-rw-r--r--x11-misc/menumaker/files/menumaker-0.99.12-AM_PATH_PYTHON.patch101
-rw-r--r--x11-misc/menumaker/menumaker-0.99.12.ebuild49
3 files changed, 151 insertions, 0 deletions
diff --git a/x11-misc/menumaker/Manifest b/x11-misc/menumaker/Manifest
index 5bd926640a2a..075a2e4b8c1d 100644
--- a/x11-misc/menumaker/Manifest
+++ b/x11-misc/menumaker/Manifest
@@ -1,2 +1,3 @@
DIST menumaker-0.99.10.tar.gz 202580 BLAKE2B 2fb53359a6e4b14fe8966c3fbb6d0f381a3ad9e52463d37edbef47a409b0ecf4f17bd7221395987d4cd49f363007aa97f0d6182595a571f1baab4e7977c06bff SHA512 e7a731ac848089cbdb845fdb0e344b48e70d3bb7220870127d3616549d31fa62b61a48e3efff52d7767b597a4407a8548e776c16976072d0aa7f5c96740cd207
DIST menumaker-0.99.11.tar.gz 205196 BLAKE2B 5f1fa9cbf4fd739499db86f9173fbbea2c96900597d13185f2a2f2b5746a0a2c05d12b115782488cb5b1df1f48638bb831dbee4bb14c414fc11328f43d241c46 SHA512 b45b8f2de4e63bad673bf4463ac074b068d4889cf37644962d51e1514d07bef827679d060d1503e59ea4bfc460fdc643d850921b3a02babd1ea57249511ffa5a
+DIST menumaker-0.99.12.tar.gz 206208 BLAKE2B c909a103bd031f385a1b7c19c8f17ac97310b3f19b2cf3eeb4b77ebfa82ac388cb9d76b1c88523942ce9d20016ba86bd4fa3741b31e3f6cd9ca63e10c8cab65e SHA512 dceef85da4d68a7f13bb59e1d93a51632d4134e55c59fa9cdf4ec4497eb502959c1b65ccaa56c2410f2fc5a770a9b023ddec05e80d186c88cdc1a351e1869af6
diff --git a/x11-misc/menumaker/files/menumaker-0.99.12-AM_PATH_PYTHON.patch b/x11-misc/menumaker/files/menumaker-0.99.12-AM_PATH_PYTHON.patch
new file mode 100644
index 000000000000..4df6939ce019
--- /dev/null
+++ b/x11-misc/menumaker/files/menumaker-0.99.12-AM_PATH_PYTHON.patch
@@ -0,0 +1,101 @@
+diff --git a/Makefile.am b/Makefile.am
+index b00b7bc..e1395ac 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,15 +1,54 @@
+-ACLOCAL_AMFLAGS = -I m4
+-
+ SUBDIRS = doc
+
+ dist_bin_SCRIPTS = mmaker
+
+-nobase_dist_pkgdata_DATA = *.py MenuMaker/*.py Prophet/*.py Prophet/Desktop/*.py Prophet/Legacy/*.py Prophet/Debian/*.py Prophet/Debian/menu/*
++python_PYTHON = \
++ Config.py \
++ Keywords.py \
++ Paths.py
++
++pythonMenuMakerdir = $(pythondir)/MenuMaker
++pythonMenuMaker_PYTHON = \
++ MenuMaker/BlackBox.py \
++ MenuMaker/CLI.py \
++ MenuMaker/Deskmenu.py \
++ MenuMaker/FluxBox.py \
++ MenuMaker/IceWM.py \
++ MenuMaker/__init__.py \
++ MenuMaker/JWM.py \
++ MenuMaker/OpenBox3.py \
++ MenuMaker/PekWM.py \
++ MenuMaker/WindowMaker.py \
++ MenuMaker/xBox.py \
++ MenuMaker/Xfce4.py
++
++pythonProphetdir = $(pythondir)/Prophet
++pythonProphet_PYTHON = \
++ Prophet/Categories.py \
++ Prophet/__init__.py
++
++pythonProphetDesktopdir = $(pythondir)/Prophet/Desktop
++pythonProphetDesktop_PYTHON = \
++ Prophet/Desktop/__init__.py
++
++pythonProphetLegacydir = $(pythondir)/Prophet/Legacy
++pythonProphetLegacy_PYTHON = \
++ Prophet/Legacy/Development.py \
++ Prophet/Legacy/Editor.py \
++ Prophet/Legacy/Emulator.py \
++ Prophet/Legacy/Graphics.py \
++ Prophet/Legacy/__init__.py \
++ Prophet/Legacy/Multimedia.py \
++ Prophet/Legacy/Network.py \
++ Prophet/Legacy/Shell.py
+
+-install-exec-local :
+- echo "#!/usr/bin/env $(PYTHON_BIN)" > $(DESTDIR)/$(bindir)/mmaker
+- echo "import sys; sys.path = ['$(pkgdatadir)'] + sys.path" >> $(DESTDIR)/$(bindir)/mmaker
+- echo "import MenuMaker.CLI" >> $(DESTDIR)/$(bindir)/mmaker
++pythonProphetDebiandir = $(pythondir)/Prophet/Debian
++pythonProphetDebian_PYTHON = \
++ Prophet/Debian/__init__.py
+
+-install-data-local :
+- $(PYTHON) -c 'import compileall; compileall.compile_dir(dir="$(DESTDIR)/$(pkgdatadir)", ddir="$(pkgdatadir)")'
++pythonProphetDebianMenudir = $(pythondir)/Prophet/Debian/menu
++dist_pythonProphetDebianMenu_DATA = \
++ Prophet/Debian/menu/debian-2.2r5 \
++ Prophet/Debian/menu/debian-8.1 \
++ Prophet/Debian/menu/ubuntu-5.04 \
++ Prophet/Debian/menu/ubuntu-5.10
+diff --git a/configure.ac b/configure.ac
+index 9ffeee7..604af4e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,22 +2,12 @@ AC_INIT(MenuMaker, 0.99.12)
+
+ AM_INIT_AUTOMAKE
+
+-#AZ_PYTHON_DEFAULT
++AM_PATH_PYTHON
+
+-#AZ_PYTHON_WITH
+-
+-#if test -z "$PYTHON"; then
+-# AZ_PYTHON_PATH
+-#fi
+-
+-#AZ_PYTHON_VERSION_ENSURE([2.7])
+-
+-#AZ_PYTHON_RUN
+-
+-AX_PYTHON
+-
+-AC_CONFIG_FILES([Makefile])
+-AC_CONFIG_FILES([doc/Makefile])
+-AC_CONFIG_FILES([Config.py])
++AC_CONFIG_FILES([
++ Makefile
++ doc/Makefile
++ Config.py
++])
+
+ AC_OUTPUT
diff --git a/x11-misc/menumaker/menumaker-0.99.12.ebuild b/x11-misc/menumaker/menumaker-0.99.12.ebuild
new file mode 100644
index 000000000000..311238de9188
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.99.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/texinfo )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-AM_PATH_PYTHON.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf PYTHON="${EPYTHON}"
+}
+
+src_compile() {
+ default
+ use doc && emake html
+}
+
+src_install() {
+ default
+ use doc && emake DESTDIR="${D}" install-html
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/mmaker
+}