summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-21 05:24:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-21 05:24:37 +0100
commitae8b1161c4cf795df7f7c73a43bdb08a70cf22b7 (patch)
tree36ddc056726d9560f3b6cf88bb6dbf79ac1aeba5
parentdev-python/coverage: Bump to 7.3.4 (diff)
downloadgentoo-ae8b1161.tar.gz
gentoo-ae8b1161.tar.bz2
gentoo-ae8b1161.zip
dev-python/alembic: Bump to 1.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.13.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 64e242aa53d0..26a56827a911 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.13.0.tar.gz 1208438 BLAKE2B e5e3040eecd74e6095062dac51138f91b79197af6410a451f7a7ac699f8d31d12ab4e381f8b1e9ce04fd8c897339d5074493e4ef95f294276ea5d67403504229 SHA512 c9a014fc30000a09fa69e7a56cb591000443317d0cc3576fd6bd70cab7cec29906fa48d57e40dcf12d7dd93762de0d6f395fb37c9d5c1780664555757f387262
+DIST alembic-1.13.1.tar.gz 1213288 BLAKE2B 12c01f60a564c3021b3d2ae61f220822a0ca644af5097b72a826f48d04225c441f580204680674410e6e2570b5c7ee24053024863162d7d43bc423a86cddcea6 SHA512 2a5826461bec22c2efc244dd8394d34d39ed6e3511a32e8e460057ab34f9e559d28dda4ea7e34ccd30628e889a3cb37cb156596e37dba748c12a0195d78aa678
diff --git a/dev-python/alembic/alembic-1.13.1.ebuild b/dev-python/alembic/alembic-1.13.1.ebuild
new file mode 100644
index 000000000000..5d610b87ddda
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}