summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2023-07-18 19:23:06 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-07-28 17:06:54 +0300
commitae8d5803be2b1b139a22e5a4563e890db9d29e91 (patch)
tree2656a831ba1b0acad01245d74ed7c68404bc6c7a
parentmedia-gfx/gnofract4d: drop 4.3_p20211108, 4.3_p20221114 (diff)
downloadgentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.tar.gz
gentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.tar.bz2
gentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.zip
media-gfx/gnofract4d: add 4.3_p20230717
Closes: https://bugs.gentoo.org/890796 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31946 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/gnofract4d/Manifest1
-rw-r--r--media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/gnofract4d/Manifest b/media-gfx/gnofract4d/Manifest
index 9201b52ae77c..a72b7ece14c3 100644
--- a/media-gfx/gnofract4d/Manifest
+++ b/media-gfx/gnofract4d/Manifest
@@ -1 +1,2 @@
DIST gnofract4d-4.3_p20221125.tar.gz 18275177 BLAKE2B 24fcd71818a98a3137b485046f295b523884d05ece694e37cf871e1fdaba7b26ac870675895a7a361e5d1fe142b0ae68c720c6e39615226951e8e1af6f57c848 SHA512 75d8d12441a0e2024f0ef125fee5cbe8dcc10c4c48ba366d5529644ae743928b998f85369aafc6e737cb994a82ebdcbe941e11c916c0d0996e785a146469e359
+DIST gnofract4d-4.3_p20230717.tar.gz 18275492 BLAKE2B 0bc8834c6f3ed3ec48bf4ee49ad563ce6842485dd32eb568c580d74528d062dcad6f8da4a67434c3784497883d0a73d4fa050a346ef970ac348db58bc6e7ea39 SHA512 c427c42e75b830dcf95012346d2db3a9b63be4e5431e7eae5ec74b915f5eedd857d8fa56d5ec37e8d245c3a77dc413c72115700d614205bdd62b916e6865f749
diff --git a/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild b/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild
new file mode 100644
index 000000000000..f29c0f35e3e3
--- /dev/null
+++ b/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature virtualx xdg
+
+COMMIT="47d2093e8f6399d1badfba0d1cb0f9867e90b326"
+
+DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
+HOMEPAGE="https://fract4d.github.io/gnofract4d/"
+SRC_URI="https://github.com/fract4d/gnofract4d/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:0=
+ media-libs/libpng:0="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gui-libs/gtk:4[introspection]"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ media-video/ffmpeg[vpx,zlib]
+ )"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ sed -i -e "s:VERSION = '4.3':VERSION = '$PV':" fract4d/options.py || die
+ sed -i -e "s:share/doc/gnofract4d/:share/doc/${PF}/:" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ ln -s "${BUILD_DIR}"/lib/fract4d/*.so fract4d/ || die
+ local EPYTEST_IGNORE=(
+ # test_regress.py does not provide pytest with any tests and inspecting it requires dev-python/pillow
+ test_regress.py
+ )
+ use x86 && local EPYTEST_DESELECT=(
+ # https://bugs.gentoo.org/890796
+ test_fractal.py::Test::testDiagonal
+ test_fractal.py::Test::testRecolor
+ )
+ TMPDIR="${T}" virtx epytest
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "creating videos" media-video/ffmpeg[vpx,zlib]
+}