summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-08 12:20:26 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-08 12:20:26 +0200
commitae91dc6c2610f799b71f647121b5c9afdde7eab8 (patch)
tree6c8d05af52abffd90c5dc41c224f5f58164e1b71
parentsci-libs/dlib: add 19.24.2 (diff)
downloadgentoo-ae91dc6c2610f799b71f647121b5c9afdde7eab8.tar.gz
gentoo-ae91dc6c2610f799b71f647121b5c9afdde7eab8.tar.bz2
gentoo-ae91dc6c2610f799b71f647121b5c9afdde7eab8.zip
dev-python/brython: add 3.11.2
Closes: https://bugs.gentoo.org/896756 Closes: https://bugs.gentoo.org/893580 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.11.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index a8a571293d4f..ded94fb7a3c6 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,2 +1,3 @@
DIST brython-3.10.5.tar.gz 11106672 BLAKE2B 4219bdb99efd666e37ee08283e58f288e06dac52454931f72bcb4f3bf61a380fb1e01d724f49e598f6d7a95260609767d4536b5f04531939daaf93db6cdb23ad SHA512 7d2f50f94c9762d6587a9b0ed76805b14a5c2c89c0d27c7e181a3e3abdcdd28c9691fb80cd472f635f5bc6c36c884becd9a5625da4825d551b57b6b0779d3529
+DIST brython-3.11.2.gh.tar.gz 11827073 BLAKE2B d1f40eae0b42f1c7a4ea086de8d83baf23dafae9333faa25578e38d4dd34e80b471ae5ad73ce107fd26a014984f92ce2b6ef399e92da7c15b9a1374794d91011 SHA512 1f0d06ae6d6523fb8f99a4ff407783b677063e99f278e1a860a422535695d2f67d98d9ccea02968dd15a52998bd34620dd54f758d5f7f4a4668e9bc621680172
DIST brython-3.11.gh.tar.gz 11684005 BLAKE2B d2ec61082787bbb571fa3a7239bad4e5d633e20f392684c532477d23ab7480dc0c3cd30a837c32fae57c88fa1779afec71bc7adb63bb4abd8f6d2d78717d55ef SHA512 98ee9c8cf1b3f8103310cf08b639fcea6675d178aedde5f425d3b44eac74552e569a8abca8cb6935cfcfc43a009ea73abbc646557a2bda916e5328a8933bea0d
diff --git a/dev-python/brython/brython-3.11.2.ebuild b/dev-python/brython/brython-3.11.2.ebuild
new file mode 100644
index 000000000000..b069ff4db898
--- /dev/null
+++ b/dev-python/brython/brython-3.11.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit webapp python-single-r1
+
+DESCRIPTION="Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="
+ https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}