summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-11 22:47:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-11 22:47:32 +0300
commitae9348c5df05918bd624d3eb6070093d37b8cc59 (patch)
tree99e310adf283e4aa48d183c4973f2b48954b3934
parentdev-python/sentry-sdk: add 1.7.0 (diff)
downloadgentoo-ae9348c5.tar.gz
gentoo-ae9348c5.tar.bz2
gentoo-ae9348c5.zip
dev-python/reportlab: add 3.6.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.6.11.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 4110f67cf890..c26c138f4ee9 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,5 +1,6 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-3.6.10.tar.gz 4518482 BLAKE2B be43079f4695bf20804864e5e0a4957093e657516dd6da45ca6b51a5da4522bed80ee0050fdd213c1fa6556c6c3e3c0173829fdc336c0d63b92ef3560c351675 SHA512 b079db8a51c917de1ab6f27d4ba733568e425fb73041331a9da842cdc00f583fb4196e5fa2a5cbdd3fb7f3681bba850950d5b391a38cbbf25ae904b88d0c278c
+DIST reportlab-3.6.11.tar.gz 4519404 BLAKE2B a099a4adcaf7186cbb558ba708abf47019cff33c6a5335b27bb1eb1377c3276ae9ecdf33e66f614880de2f72e195333f3a7839ce776b8946431e2d23872fb13b SHA512 2ef81850f4e30e78ef9e923d3aea7efac6c98dce83f90c0edd47384febd68eb6ac81e05c7038e7d67458bdae16d1b19b75e9aeb8da6a5283e9173e27e4369251
DIST reportlab-3.6.6.tar.gz 4509457 BLAKE2B d2cb5c764aa86000dd97798b5aea25fdc07e4230015dda6c11099e379884ca74532327dfe723069d5e56569dd7e120d94918f64a5f705bfef212b484f812aa7b SHA512 6f05e5f7c6b6c0b6f8d65fe11e2900ecd427f6c293672b12a4cc094476da1cdebc0df59198660614251d388241d7c886c345f958d337d351ea048b3b25a71ba5
DIST reportlab-3.6.7.tar.gz 4504447 BLAKE2B 3e691294d20f94850840ddc70565d2235bdcb37d47b5e869e34e5fea93dc9ba017d09f088e18b6479266354076b89461849dd1eb7d1d4e8b12a9c4a95706bf66 SHA512 51f98900ccf7ef34fefc237bf1c787931a525cd82284685bda26f411760b97d1b85fce5bffa59b133705f6c1769a8d3616ef85ea368ed59dfc72f24d5faf6e88
DIST reportlab-3.6.8.tar.gz 4503191 BLAKE2B 3d61ac2554309a8dfff2107ba6157152b558355fc6ebd7d2337b0f3152ceb9644ae2dc20b6e0f2ed312a579fc5f172e05eeda69e3b6acbbf921b62f27ce50f77 SHA512 7eb2381a8020f751f03008bb8dc1eb07f954a97c0c3d38646602a22ed7f69dd73e11bbd1251a471da141c98492be7f3867cf120e489c58911ae6e9f29c926507
diff --git a/dev-python/reportlab/reportlab-3.6.11.ebuild b/dev-python/reportlab/reportlab-3.6.11.ebuild
new file mode 100644
index 000000000000..1ffad971fbde
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.6.11.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6.9-paths.patch
+)
+
+distutils_enable_sphinx docs/source
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ cat > local-setup.cfg <<-EOF || die
+ [OPTIONS]
+ no-download-t1-files = 1
+ use-system-libart = 1
+ EOF
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}