summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 22:37:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 22:59:54 +0200
commitae968b68b4e1d5d71a6acc32f582eeccbf59539c (patch)
tree2d788de482e9a2f05304ab3bf5031b3bd9c4d1a6
parentnet-libs/openmq-cclient: Remove last-rited package (diff)
downloadgentoo-ae968b68b4e1d5d71a6acc32f582eeccbf59539c.tar.gz
gentoo-ae968b68b4e1d5d71a6acc32f582eeccbf59539c.tar.bz2
gentoo-ae968b68b4e1d5d71a6acc32f582eeccbf59539c.zip
dev-python/PySDL2: Bump to 0.9.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PySDL2/Manifest1
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.9.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/PySDL2/Manifest b/dev-python/PySDL2/Manifest
index c12a1859fddb..5dbc4f6a789b 100644
--- a/dev-python/PySDL2/Manifest
+++ b/dev-python/PySDL2/Manifest
@@ -1,2 +1,3 @@
DIST PySDL2-0.9.7.tar.gz 1079253 BLAKE2B 986a21d8c2f4f45df683d85a8369be7b39f102e59a1b3fd37e2941065a1174d5cd6dd056f78fbc66663e2cf50228ee40abf67352e5ae75176a9c000fb6f672fb SHA512 10d40063762272eaaae1cb6290e007481887806938ba0ba17d28974a3a3c8b36570054587001d00eb9ab4aa2375c616c43a81c7e7308fbb9b61b55b3eb7da5ac
DIST PySDL2-0.9.8.tar.gz 742279 BLAKE2B 403fba93f446f6eeb8c3b365f02207e5447c4fc16a08835ef81a1846491a4a3745ea1b7694f3b5ec3e7058975f33c20885065a4521f50aaf5c290728dbac9dd0 SHA512 674af175b1c5bd9b4100f94738c41b9b5517d2d536a7d6f7a356aafa81b67bce8349c74c166ae9289b8f746a9a16c785f88595bc48399d834d62af5355c59344
+DIST PySDL2-0.9.9.tar.gz 743302 BLAKE2B 1e9e0eeea48b838227d3fe6ea93311d445b1d3a15588f4b83d075d18306b419ba3512826e44c5e4ecc2aec59ad44da73372ec740ebf6106271fd0b77175b88d7 SHA512 52b469735b1229392ea2f73b2dfcf1e75cedf7582a488461be9b06bc072f82a5c8c559d345a0c3668829c0f8bb2996005d538465ed7d2a45fb8480001fd0ccce
diff --git a/dev-python/PySDL2/PySDL2-0.9.9.ebuild b/dev-python/PySDL2/PySDL2-0.9.9.ebuild
new file mode 100644
index 000000000000..e3b42a45db2c
--- /dev/null
+++ b/dev-python/PySDL2/PySDL2-0.9.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
+HOMEPAGE="https://github.com/marcusva/py-sdl2 https://pypi.org/project/PySDL2/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Optional deps:
+# - dev-python/numpy,
+# - dev-python/pillow,
+# - media-libs/sdl2-* (loaded dynamically via ctypes).
+#
+# If a reverse dependency needs the specific module, it should
+# explicitly depend on the optional module in question. You also
+# probably need to explicitly require some media-libs/libsdl2 flags.
+RDEPEND="media-libs/libsdl2"
+
+# Require all of SDL2 libraries and at least the most common subsystems
+# for better test coverage.
+DEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
+ || (
+ media-libs/sdl2-mixer[flac]
+ media-libs/sdl2-mixer[midi]
+ media-libs/sdl2-mixer[mod]
+ media-libs/sdl2-mixer[mp3]
+ media-libs/sdl2-mixer[opus]
+ )
+ media-libs/sdl2-ttf
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # from .travis.yml
+ local -x SDL_VIDEODRIVER=dummy
+ local -x SDL_AUDIODRIVER=dummy
+ local -x SDL_RENDER_DRIVER=software
+
+ distutils-r1_src_test
+}