summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-12-01 15:59:13 +0100
committerDavid Seifert <soap@gentoo.org>2018-12-01 16:00:03 +0100
commitaead08dce29f698e814cd37ce92c5d44036a6b1e (patch)
tree80e4e0976c008e3d901154df533424521d3580f8
parentdev-lang/ruby: stable 2.4.5 for ia64, bug #661262 (diff)
downloadgentoo-aead08dc.tar.gz
gentoo-aead08dc.tar.bz2
gentoo-aead08dc.zip
dev-ros/hector_pose_estimation: Fix for deprecated pluginlib macro
Closes: https://bugs.gentoo.org/653184 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch19
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild4
2 files changed, 22 insertions, 1 deletions
diff --git a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
new file mode 100644
index 000000000000..a226c40e9fce
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
@@ -0,0 +1,19 @@
+From 6743fbe859981c2b52a2ab413175d7d2eaf33b47 Mon Sep 17 00:00:00 2001
+From: Mikael Arguedas <mikael@osrfoundation.org>
+Date: Fri, 27 Oct 2017 15:08:45 -0700
+Subject: [PATCH] update to use non deprecated pluginlib macro
+
+---
+ hector_pose_estimation/src/pose_estimation_nodelet.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hector_pose_estimation/src/pose_estimation_nodelet.cpp b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
+index 7da3ca6..97ba5b0 100644
+--- a/hector_pose_estimation/src/pose_estimation_nodelet.cpp
++++ b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
+@@ -55,4 +55,4 @@ class PoseEstimationNodelet : public PoseEstimationNode, public nodelet::Nodelet
+ } // namespace hector_pose_estimation
+
+ #include <pluginlib/class_list_macros.h>
+-PLUGINLIB_DECLARE_CLASS(hector_pose_estimation, PoseEstimation, hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
++PLUGINLIB_EXPORT_CLASS(hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
index 7cc3dd4e6490..284a8883bbab 100644
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,3 +26,5 @@ RDEPEND="
"
# dev-ros/hector_timing
DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.0-pluginlib.patch )