summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 05:11:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 05:56:59 +0100
commitaee3c1c4ed4ee962a247697822edb304e3873c85 (patch)
tree6e9a9682497492c234eeb47c93ce0c95eb507f5e
parentdev-python/boto3: Bump to 1.26.61 (diff)
downloadgentoo-aee3c1c4.tar.gz
gentoo-aee3c1c4.tar.bz2
gentoo-aee3c1c4.zip
app-admin/awscli: Bump to 1.27.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.61.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index af1db5dab645..eae08953fd67 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.57.gh.tar.gz 2359650 BLAKE2B 637674f1726828b43a8135b9f7ff9d1f4
DIST aws-cli-1.27.58.gh.tar.gz 2359921 BLAKE2B da3ead9140407faff60384fa7aafbc27a8a86d088e4516599e573b9e968f00d3e292a8ea6a0eb0a80449f1fef3bb62204dad2a788f10ba87a959218d909da77b SHA512 2bc4dfe5058c847510f4f43006191153b23e5efecc51bb010f9b06ba127504ee40c953bcb6e47d921760f1bc6eb87747971a9a3514f781dd4bd76f30ecd7de81
DIST aws-cli-1.27.59.gh.tar.gz 2360458 BLAKE2B e60117e41cf95d442db333cf49c146e4ed02247007b8f46228799c5dee8c486aec34b236c9a0a6d152d690ff86c34fd797a6f35227a6e443805cdfe1b1b30f00 SHA512 87b9aebe812415223285c09ab5a36de2b9c0da49775d1162a5b5d7489ad61c16ca5361b721bc9e4ec4ccc09306be24513f42d7263b315d6856be20fdf0779686
DIST aws-cli-1.27.60.gh.tar.gz 2361068 BLAKE2B ee5b5b1129bcdfe261d0b7ddbfa905b4c97a799ba7c494cad74bcb3c74dcff39131b908d602a60c023c26cf4c733a52b385c4ad8266c53e5d60d8036c5abd2e6 SHA512 aa14729040d4dcfdbb75936eb29d651c03ea28a3c18f5ad4b9e685899e07f03703f2058d508a16c753df1b1e66af3ff84ec9e31476fc2f969786235ce15ae425
+DIST aws-cli-1.27.61.gh.tar.gz 2362178 BLAKE2B 512fd70f5688289b79807e679aded5085af89a14e5724dc70a771fed846060a4ef1265b3ef9d598c24d228649412204cf48d02a2ff840575a8e9a3fc3a2fe12a SHA512 c8b0640fd2aba05617e3ed60d5cfc6749102e16477eaae2e94d5be7750d5bfea14c8020a4dc7bac5c2b2bae2f46f302930b03b6d47a1cf778ae08be761f7274f
diff --git a/app-admin/awscli/awscli-1.27.61.ebuild b/app-admin/awscli/awscli-1.27.61.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.61.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}