summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 14:23:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 14:27:36 +0100
commitaef0f93c7eb59a41ba7893041bb29132f3992ab0 (patch)
tree674bf1ce4483afc5df40645c996e714b494326c7
parentdev-ros/dynamic_reconfigure: bump to 1.7.2 (diff)
downloadgentoo-aef0f93c7eb59a41ba7893041bb29132f3992ab0.tar.gz
gentoo-aef0f93c7eb59a41ba7893041bb29132f3992ab0.tar.bz2
gentoo-aef0f93c7eb59a41ba7893041bb29132f3992ab0.zip
media-libs/kvazaar: bump to 2.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/kvazaar/Manifest1
-rw-r--r--media-libs/kvazaar/kvazaar-2.1.0.ebuild64
-rw-r--r--media-libs/kvazaar/kvazaar-9999.ebuild4
3 files changed, 67 insertions, 2 deletions
diff --git a/media-libs/kvazaar/Manifest b/media-libs/kvazaar/Manifest
index 5544282afc6c..0082a0d84727 100644
--- a/media-libs/kvazaar/Manifest
+++ b/media-libs/kvazaar/Manifest
@@ -1,3 +1,4 @@
DIST greatest-1.2.1.tar.gz 19792 BLAKE2B e6abd20eebf3223311fcd62e341595318dd00f192cf4b62ef3f0443a3e10fee71f4283f836931fee52672f2b37398f86046ae97220c2b6c6045fec9f9bf5cda8 SHA512 c17162fa222c84fef7826ba5202aae573d516a71bc2c59c8991db2a76f7069ed53d00aaab1b792e0c7e4243fae38183764c2e7ae0a61faf2ff13e78b29ccc211
DIST kvazaar-1.2.0.tar.gz 486455 BLAKE2B e7b9ceee4e4edeb051128cfa798e59114cd9175b5ba8a4531c7e872327658c58d22ad21ce40b1b71c632e94cef96b78b77646048629683d24bf69107497f1acd SHA512 5a28c1b21e47d9f45e04ee40a253f478c4ce3c6c41134db8301e843ef0b5d620bce493eacf82ce1ddda88140aa4d2e9401612b63ff592fc2273cf532458d2bb4
DIST kvazaar-2.0.0.tar.gz 589661 BLAKE2B 253085784bb3481b578206d5a406d0c25c002905f420337939489d01604f7b5f4ee13a17e596ce96e5d577c508f93f72d2befa5851ab95d7ba9db2030de02550 SHA512 9b2564643f4470d59160f7addffbc6b9e22c0d8bd04dbcd77705aa7263dfdc0195a8642255c45b94049b88ba9cbf4ffd49f968d766e31bc404c612b8f18bdbca
+DIST kvazaar-2.1.0.tar.gz 605962 BLAKE2B 0d61af55ab0caef2247524e8c564f9c24cfb479fcbd721f43e4409899e1a187a0e6de0b08a052cfb144ea31da906ba1c2160d6712828d6e55f0826d87f5c96ba SHA512 14b29f48908e004cf1b4f1f0c338b7b134a34140edcd58a645b4529c506cd567ebe3d56aa66e469dc417e1baa29bb8a476825b78825e810ac68a029191ad32ec
diff --git a/media-libs/kvazaar/kvazaar-2.1.0.ebuild b/media-libs/kvazaar/kvazaar-2.1.0.ebuild
new file mode 100644
index 000000000000..5e1ab5d32af7
--- /dev/null
+++ b/media-libs/kvazaar/kvazaar-2.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GREATEST_PV="1.2.1"
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
+else
+ SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Open-source HEVC encoder"
+HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
+
+LICENSE="LGPL-2.1"
+# subslot = libkvazaar major
+SLOT="0/6"
+IUSE="static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RESTRICT="!test? ( test )"
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ media-video/ffmpeg
+ )
+ abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+"
+
+src_prepare() {
+ default
+ sed -e "/^dist_doc_DATA/s/COPYING //" -i Makefile.am || die
+ eautoreconf
+ if use test && [[ ${PV} != *9999 ]]; then
+ # https://bugs.gentoo.org/show_bug.cgi?id=595932
+ rmdir "${S}/greatest" || die
+ mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
+ fi
+ # Some m4 macros append Werror, we do not want that.
+ append-flags "-Wno-error"
+
+ # valgrind isn't available on all archs
+ # also, the valgrind tests fail with new ffmpeg (upstream only tests again ffmpeg 2.6.3)
+ # see https://github.com/ultravideo/kvazaar/issues/216
+ find "${S}/tests/" -type f -exec grep -q 'valgrind_test' '{}' \; -delete || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/kvazaar/kvazaar-9999.ebuild b/media-libs/kvazaar/kvazaar-9999.ebuild
index f0ff4dca3520..5e1ab5d32af7 100644
--- a/media-libs/kvazaar/kvazaar-9999.ebuild
+++ b/media-libs/kvazaar/kvazaar-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ if [[ ${PV} = *9999 ]] ; then
else
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
inherit autotools flag-o-matic multilib-minimal toolchain-funcs