summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-24 22:03:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-24 22:05:54 +0300
commitaef15cead4222d91cf4956a3eac3e678c918036a (patch)
treeabe433d7daa78af22de8bdacc3f50c2b192f4e13
parentdev-python/pyopenssl: add 23.1.0 (diff)
downloadgentoo-aef15cead4222d91cf4956a3eac3e678c918036a.tar.gz
gentoo-aef15cead4222d91cf4956a3eac3e678c918036a.tar.bz2
gentoo-aef15cead4222d91cf4956a3eac3e678c918036a.zip
dev-python/jupyterlab-server: add 2.21.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.21.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index 37f7508e1ff9..01ef8c4e4a05 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.20.0.tar.gz 70481 BLAKE2B 188b8a9bd2bfc5a27ce6f8488d7768484fd71ae8bb93f28c8a49f63b1aef13551c55d7e18531830df26617883f6b780a491d3522a0dcb3ecddcc433cfb35f97b SHA512 7d9a86f56686344ffc1ad11a9fc7c736a2ac0e6b8c31f8b6d8e35e5fd982454b2362073038dfc2ed3a4f03ef53e2afcaa33fc2c956b63e44c3d1ae6efa1f9251
+DIST jupyterlab_server-2.21.0.tar.gz 70965 BLAKE2B bb959d2c5a507ac6ad2ed719e86a68590c51df51a126f8a44195c48ccb9a295ca0930d0c106cc9f753b3032aca4002d4edadf31f24602d22bf9d3be3eabe2fdb SHA512 c3180983e6db932a4f243e977aaa0d7e7daed34788ba3a51d1414c5b625008ec524e0bf96a559bd85279146f9bd02c31eb2ac3451c40edba1751ed695c7c0791
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.21.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.21.0.ebuild
new file mode 100644
index 000000000000..c3e034e2e133
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.21.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.17[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}