summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2021-03-08 14:45:56 -0500
committerSam James <sam@gentoo.org>2021-04-05 17:45:46 +0000
commitaef561c3c28f22621e9211acfc38b2152e3c0a91 (patch)
tree77f1e185099912f735d90b189abeda3328d20fe4
parentgames-roguelike/adom: add missing inherit, fix games.eclass porting (diff)
downloadgentoo-aef561c3c28f22621e9211acfc38b2152e3c0a91.tar.gz
gentoo-aef561c3c28f22621e9211acfc38b2152e3c0a91.tar.bz2
gentoo-aef561c3c28f22621e9211acfc38b2152e3c0a91.zip
games-roguelike/hengband: update to EAPI 7
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-roguelike/hengband/hengband-1.6.2-r1.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/games-roguelike/hengband/hengband-1.6.2-r1.ebuild b/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
index 15fcc0210076..14049bd919ef 100644
--- a/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
+++ b/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools
+EAPI=7
+inherit autotools eutils
DESCRIPTION="An Angband variant, with a Japanese/fantasy theme"
HOMEPAGE="http://hengband.sourceforge.jp/en/"
SRC_URI="mirror://sourceforge.jp/hengband/10331/${P}.tar.bz2
mirror://gentoo/${P}-mispellings.patch.gz"
-KEYWORDS="~x86"
LICENSE="Moria"
SLOT="0"
+KEYWORDS="~x86"
IUSE="X l10n_ja"
RDEPEND=">=sys-libs/ncurses-5:0
@@ -20,23 +20,23 @@ DEPEND="${RDEPEND}
X? ( x11-libs/libXt )"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-1.6.2-added_faq.patch"
+ "${FILESDIR}/${PN}-1.6.2-autoconf-ncurses.patch"
+ "${FILESDIR}/${PN}-1.6.2-ovflfix.patch" )
+
src_prepare() {
# Removing Xaw dependency as is not used
- sed -i \
- -e '/Xaw/d' src/main-xaw.c \
- || die
- sed -i \
- -e 's|root\.|root:|' lib/*/Makefile.in \
- || die
- sed -i \
- -e 's:/games/:/:g' configure.in \
- || die
- epatch \
- "../${P}"-mispellings.patch \
- "${FILESDIR}/${P}"-added_faq.patch \
- "${FILESDIR}"/${P}-ovflfix.patch \
- "${FILESDIR}/${P}-autoconf-ncurses.patch"
+ sed -i -e '/Xaw/d' src/main-xaw.c || die
+ # Fix syntax for chown
+ sed -i -e 's|root\.|root:|' lib/*/Makefile.in || die
+ # Don't target the games sub-dir, since we're not using games.eclass any
+ # more
+ sed -i -e 's:/games/:/:g' configure.in || die
+
+ default
+
mv configure.in configure.ac || die
+
eautoreconf
}