summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-15 06:26:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-15 06:26:46 +0100
commitaf1735b09d3cb56cfc42a356a605121f664384ea (patch)
treeffeb5b7ff9a631ee7209406fd9c6fc8ae8073ab8
parentdev-ros/gazebo_plugins: Bump to 2.7.4. (diff)
downloadgentoo-af1735b09d3cb56cfc42a356a605121f664384ea.tar.gz
gentoo-af1735b09d3cb56cfc42a356a605121f664384ea.tar.bz2
gentoo-af1735b09d3cb56cfc42a356a605121f664384ea.zip
dev-ros/gazebo_ros: Bump to 2.7.4.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index 607f672d3bf5..246fd0bcaf51 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1,3 +1,4 @@
DIST gazebo-ros-2.7.3-patches-1.tar.bz2 19057 BLAKE2B ee8040e7f25d734d31c32963d47601b908b153a55294e736e49d1a10ea14a9ed74133e547eb1abf5d50ee70814f6b3476433e835cc604798057cb9d5a698a3aa SHA512 12ec281277f83c7a267fc111ec029b732435f50f320c74255eeb8e8ea7b38aa8771d08c9815d6525b22b7f2fe706aae087a33591082cddbcf7a46742a35ae0fb
DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 BLAKE2B 8365084619d57d8427753e33d4a3128162c44b10552166c7070eaabde3f806cee9981c60b30b18b6cbe80b83e2871b0100b51329a1a6bd9747320245f21ec1a4 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3
DIST gazebo_ros_pkgs-2.7.3.tar.gz 1836260 BLAKE2B 7867bec1461769923ba36ea2e56b21d85cf1db254cd50a028af5953fe1b5373015b68785a90d242e245d12a2da2c7a8ff26db66c0c466e6a6e029fbb74340a06 SHA512 66590a248f0813ab0f2a80df234f9dd8d448c500726b62d3fc74397d3a618d6fae994c3e463bb0c4a8892cef35ba1729229c471f3d21d4b3a2091d5ad74cc33b
+DIST gazebo_ros_pkgs-2.7.4.tar.gz 1839281 BLAKE2B 3a8342465e69c6b7d986b6a9f04b42451479434839a10ecebc1993ad57ffecf78b1f67013fe54919477a252ef547ab5ed768b4f0303de7395e6a693e1aafced1 SHA512 43c1fed13a653a93df85110d49fcd5d324b80e080cdef08ad15cd293d25b0eca59ec9610e420074f2bf406567a79a8c0b8ae88a289981626f2f5be1dc8b06c22
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild
new file mode 100644
index 000000000000..ca217b085352
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"