summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-30 22:18:26 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-30 22:18:26 -0400
commitaf40b12d48b507c99b68cd41aa0bd936cbd299f0 (patch)
treef8132d298e657470d530ef31846b6108bc70fa23
parentmail-client/thunderbird: x86 stable (bug #669960) (diff)
downloadgentoo-af40b12d.tar.gz
gentoo-af40b12d.tar.bz2
gentoo-af40b12d.zip
dev-python/pygments: fix build with USE="doc"
Closes: https://bugs.gentoo.org/662640 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/pygments/files/pygments-2.2.0-sphinx17.patch22
-rw-r--r--dev-python/pygments/pygments-2.2.0-r1.ebuild55
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch b/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
new file mode 100644
index 000000000000..bb7c6074ff9d
--- /dev/null
+++ b/dev-python/pygments/files/pygments-2.2.0-sphinx17.patch
@@ -0,0 +1,22 @@
+# HG changeset patch
+# User WAKAYAMA Shirou <shirou.faw@gmail.com>
+# Date 1500298269 -32400
+# Node ID 1a78f58afb5066cf35b04676d0d5ffbb18d5d540
+# Parent 7941677dc77d4f2bf0bbd6140ade85a9454b8b80
+Change to docutils.parsers in sphinxext.
+
+From Sphinx 1.7, sphinx.utils.compat will be removed.
+
+diff --git a/pygments/sphinxext.py b/pygments/sphinxext.py
+--- a/pygments/sphinxext.py
++++ b/pygments/sphinxext.py
+@@ -16,7 +16,7 @@
+
+ from docutils import nodes
+ from docutils.statemachine import ViewList
+-from sphinx.util.compat import Directive
++from docutils.parsers.rst import Directive
+ from sphinx.util.nodes import nested_parse_with_titles
+
+
+
diff --git a/dev-python/pygments/pygments-2.2.0-r1.ebuild b/dev-python/pygments/pygments-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..617820a1b612
--- /dev/null
+++ b/dev-python/pygments/pygments-2.2.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="http://pygments.org/ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/ttf-fonts )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # fix generators for python3.7+
+ "${FILESDIR}"/pygments-2.2.0-pep479.patch
+ # Fixing USE="doc" with sphinx1.7+. bug #662640
+ "${FILESDIR}"/pygments-2.2.0-sphinx17.patch
+)
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+ # With pypy3 there is 1 error out of 1556 tests when run as is and
+ # (SKIP=8, errors=1, failures=1) when run with 2to3; meh
+ nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}