summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-02-28 10:55:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-02-28 11:05:58 +0100
commitaf459c88b6c5fdef8fca4d3c5a33aed8d0ff16a5 (patch)
treebebbd893d07e37aa38840e21b0c952cc3cfb0540
parentdev-util/bpftool: drop 5.16.10 (diff)
downloadgentoo-af459c88.tar.gz
gentoo-af459c88.tar.bz2
gentoo-af459c88.zip
media-libs/aubio: ffmpeg5 fix
from upstream Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/aubio/aubio-0.4.9-r1.ebuild1
-rw-r--r--media-libs/aubio/files/ffmpeg5.patch28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/aubio/aubio-0.4.9-r1.ebuild b/media-libs/aubio/aubio-0.4.9-r1.ebuild
index 579361fe63c9..48d70ea69fd3 100644
--- a/media-libs/aubio/aubio-0.4.9-r1.ebuild
+++ b/media-libs/aubio/aubio-0.4.9-r1.ebuild
@@ -51,6 +51,7 @@ PYTHON_SRC_DIR="${S}"
PATCHES=(
"${FILESDIR}"/${PN}-0.4.9-docdir.patch
+ "${FILESDIR}"/ffmpeg5.patch
)
src_prepare() {
diff --git a/media-libs/aubio/files/ffmpeg5.patch b/media-libs/aubio/files/ffmpeg5.patch
new file mode 100644
index 000000000000..e4901ad69c01
--- /dev/null
+++ b/media-libs/aubio/files/ffmpeg5.patch
@@ -0,0 +1,28 @@
+From 8a05420e5dd8c7b8b2447f82dc919765876511b3 Mon Sep 17 00:00:00 2001
+From: Paul Brossier <piem@piem.org>
+Date: Tue, 25 Jan 2022 18:30:27 +0100
+Subject: [PATCH 1/1] [source_avcodec] define FF_API_LAVF_AVCTX for libavcodec
+ > 59, thx @berolinux (closes gh-353)
+
+---
+ src/io/source_avcodec.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/io/source_avcodec.c b/src/io/source_avcodec.c
+index e0ae93b5..1421bd9a 100644
+--- a/src/io/source_avcodec.c
++++ b/src/io/source_avcodec.c
+@@ -68,6 +68,10 @@
+ #define AUBIO_AVCODEC_MAX_BUFFER_SIZE AV_INPUT_BUFFER_MIN_SIZE
+ #endif
+
++#if LIBAVCODEC_VERSION_MAJOR >= 59
++#define FF_API_LAVF_AVCTX 1
++#endif
++
+ struct _aubio_source_avcodec_t {
+ uint_t hop_size;
+ uint_t samplerate;
+--
+2.11.0
+