summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-13 02:57:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-13 03:01:07 +0100
commitaf5c6638cedbb02493cd9da901db39aa29d81296 (patch)
treedc88dd78725376c665c756a08806aa04be103a6f
parentdev-ml/zed: bump to 3.2.1 (diff)
downloadgentoo-af5c6638cedbb02493cd9da901db39aa29d81296.tar.gz
gentoo-af5c6638cedbb02493cd9da901db39aa29d81296.tar.bz2
gentoo-af5c6638cedbb02493cd9da901db39aa29d81296.zip
dev-ml/utop: bump to 2.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/utop/Manifest1
-rw-r--r--dev-ml/utop/utop-2.11.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/utop/Manifest b/dev-ml/utop/Manifest
index 8d4858a721cf..53a099e600f4 100644
--- a/dev-ml/utop/Manifest
+++ b/dev-ml/utop/Manifest
@@ -1,3 +1,4 @@
+DIST utop-2.11.0.tar.gz 416351 BLAKE2B 14d407bd79f83b9b0307ec34ec9330e625e0e5fbc4b4091f98a45d90ff6225c292b6d764746273a5b7e7abda74c83852056f470d8f2f3b16fffc16569ecc6f98 SHA512 ebc27219b0345ab1478499221756806874c430f81aa9f40e7d482d0fd948750919d631b6159faec19fef0d23d14e6a115e6b21a5aa724ce1534e000e5d35bdae
DIST utop-2.9.0.tar.gz 414953 BLAKE2B 96fbf38d4a638137b73264bc523b8a81e47ddd609a7987073313f4b1d628e4e84c31f98195105911dd0930b8d27007cf5cc1633771bc6d2e975bd169e1e3ba9c SHA512 dd3f52fb915493cb32b5ee722361e884a481d04ef175d5bdf58f4032b70826c38b2f5279b7c64b78961170a86bc80fbd59f03026fac99bb5da2b46a8f341aa45
DIST utop-2.9.1.tar.gz 421430 BLAKE2B c90a7fe54c5fbf15ce209e9bf850031e0368104c1f8f61a2d982b2b43d87b4bb95c91e3af6da16ae27ebfab71f2b9907e7dec68d34f619597fe8db45ff363bf4 SHA512 10942a4c7d2e13081f2e02c29b767863176fe90ca5baf48d3be47bb0871a12840d873e5d3eb7d7dd9b0362e849f70afb913ff50c07e66c6b7f221c8bb98fa469
DIST utop-2.9.2.tar.gz 421512 BLAKE2B 235b4739e644877e4b9eef432a00ba053f42f2b4d4fdd9b0bd925af736d9a351c8f9373031bc4fc23835872034d48a27b8eac99d286f57cb975d2b1368f420c8 SHA512 14dd690b459cfea90c565b397b5d914add7e92b152b476ab58576dc827fa204b3d721955bfc3508bcb953778a8d6fb3b299b0293f8ddf64b3f0155fc9a0e7fda
diff --git a/dev-ml/utop/utop-2.11.0.ebuild b/dev-ml/utop/utop-2.11.0.ebuild
new file mode 100644
index 000000000000..a975e9bda1b7
--- /dev/null
+++ b/dev-ml/utop/utop-2.11.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}