summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 13:30:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 13:34:35 -0500
commitaf64fdaf4825df3ab1197b79defbe6993e01651a (patch)
tree57e4ed941f78a34b0dbe53ff7645980a4a412d8c
parentdev-python/cmd2: 0.7.5 bup (diff)
downloadgentoo-af64fdaf.tar.gz
gentoo-af64fdaf.tar.bz2
gentoo-af64fdaf.zip
dev-python/cliff: 2.8.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-2.8.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 7b8ee6d3b79b..4cfa6ac2b6f7 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-2.4.0.tar.gz 58088 SHA256 cc9175e3c2a42bc06343290a1218bc6b70f36883520b2948f743c5f9ae917675 SHA512 2683e9c0ba56a473abfb08a4def07a1025930b9af100ba18ade7dccf1c73f2d4ddec1cd109ce948e379e41481556791c7620289af910243885a52273d936aef4 WHIRLPOOL b762fffc735ad70cc91f1dfb7a67bc62d07b1e71150e86ddbce8b8ca67ae6fce2de8fa6181b429bb616f421846dc08cc0f519b66b6717cc7ffadc4f2c2d52f45
+DIST cliff-2.8.0.tar.gz 71815 SHA256 a4fd35b3d98f5f806b6f38c97559ad671376f7d54d1e29015dbd6d805a13ff46 SHA512 a371916945ee71ec519aeb923ca44b0a0e10fe6e460d236434c5c2946ad2b517050bf9d0430bdde506bdf2d28ba60bd45941d9ce21d77a83e2d5541b088d04b3 WHIRLPOOL d2b2f0a0f0afc811a1d9df7c57dc473967bb79ab15debf6d61ca758914efa86f7d7d54308b7882ca688724462e06e72305650665b13959d33fe917e7077290a0
diff --git a/dev-python/cliff/cliff-2.8.0.ebuild b/dev-python/cliff/cliff-2.8.0.ebuild
new file mode 100644
index 000000000000..7c8c72906eb6
--- /dev/null
+++ b/dev-python/cliff/cliff-2.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ )
+"
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}