summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-12 20:11:26 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-12 20:12:30 -0400
commitaf7b6ba775cd7964c59638d82a8b8cca4418746f (patch)
treec2e630dcf6a8846117099926b2a2ab97b6d68537
parentsci-geosciences/mapserver: bump to 8.0.1 (diff)
downloadgentoo-af7b6ba775cd7964c59638d82a8b8cca4418746f.tar.gz
gentoo-af7b6ba775cd7964c59638d82a8b8cca4418746f.tar.bz2
gentoo-af7b6ba775cd7964c59638d82a8b8cca4418746f.zip
x11-libs/libXaw3d: Version bump to 1.6.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libXaw3d/Manifest1
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/Manifest b/x11-libs/libXaw3d/Manifest
index 5dcbfda1f1b2..9abfe6f0554c 100644
--- a/x11-libs/libXaw3d/Manifest
+++ b/x11-libs/libXaw3d/Manifest
@@ -1 +1,2 @@
DIST libXaw3d-1.6.4.tar.xz 482168 BLAKE2B a1e2e66ef4c5d102523080beae903b21b9b6bd0a5e4bd1e685bbfc4e1eaa3dc594f65f357d027f93808fd34d7e05ed8631fe33b6849760fc1fcc919c8b85d526 SHA512 388e905871a823d0f87fbc29e9ea2de95ac13ccaf50e031a01602d8d388d61bcf1823b4ded8c1a06bdce382e8ddcbc1b0182ccef00cde8064b09176163283dba
+DIST libXaw3d-1.6.5.tar.xz 483496 BLAKE2B 54dc1bb06b40685e3e2f00bc1aa8447a23ff61226c0b8d20cb0fe070bb7d914290cc4a5f2c70925da528bd9f02a283748178cb2b17111a56fbcc938a1eae25c9 SHA512 b2fbceffcbaff7c332f37769fd6b496ac820de8a80fbf9777416f1895b74a07e4efc3f2bd64db3f584983b24d2b10e9b60cf4aae3ec4a30c06510ae7c213a663
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.5.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.5.ebuild
new file mode 100644
index 000000000000..31c123fa2f7a
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw3d library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ app-alternatives/yacc"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-internationalization
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-gray-stipples
+ --enable-arrow-scrollbars
+ )
+ xorg-3_src_configure
+}