summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-27 14:45:31 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-27 14:46:46 -0500
commitaf8d4176feac1f87c83fb77d650567f756d80464 (patch)
tree2f83e543836bb1db78633d605f8f3f42354a868e
parentnet-analyzer/thc-ipv6: Drop old (diff)
downloadgentoo-af8d4176.tar.gz
gentoo-af8d4176.tar.bz2
gentoo-af8d4176.zip
dev-python/pluggy: bump to 0.8.1
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-0.8.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 9a7629b14248..7f3c34a19f7c 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1,3 +1,4 @@
DIST pluggy-0.5.2.tar.gz 18935 BLAKE2B 8e5bbab9ed0c78a0c6da076ad03618e66780f9ff209f4d08223e7a381eb4d7573727793f4543799e0e557991d4edcdbfd22c0565b69814379806912a4631abf3 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb
DIST pluggy-0.6.0.tar.gz 19678 BLAKE2B 79db59c5f0ce0dd157630d039ec50643f615789b6b993d84e9ab1bdc9ce04b32df336d88df13f13a16a1f0bd4acb7b900208e98c84f007bdc3654f9a1d5f19a2 SHA512 dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812
DIST pluggy-0.7.1.tar.gz 47784 BLAKE2B 49eb28779717ead8963e14101cdfb830feeecff756a59f080e79e70465d48dbbc6e6100305e8b32031cefb0ba06bb10494f29bc8ddd38d4296016ecebaafccc1 SHA512 e19f6c1b3f2e711df1c8b075a2b802751afd218f1b692f08b2434c01d71c402331ff8c937550fbdfece2098f6d6856422d485f193e188916b365ded2e4087697
+DIST pluggy-0.8.1.tar.gz 53375 BLAKE2B ca9b3e3930a193de9adc5ac4f755ce2a17e3b166d1ce71502ac744c6c175901f75e910fa51a888b5ae1b16a63b5afe77b77fdd6b5b2a584a08f985d6d34881a6 SHA512 ee7a83f7c62e4366bc7c3c2ad822c788e5cae7ac900c3d41d84ef8b8d9c4cab7c4327df86c134c19f2faaa86a049913984550dd06db9b465ad58a83566cda150
diff --git a/dev-python/pluggy/pluggy-0.8.1.ebuild b/dev-python/pluggy/pluggy-0.8.1.ebuild
new file mode 100644
index 000000000000..dd9526ce4e72
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.1-disable-broken-tests.patch"
+)
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" pytest -v || die "tests failed with ${EPYTHON}"
+}