summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-28 23:12:22 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-28 23:12:22 +0200
commitaf9298355290622e1ab2ec5253550e6b8196722a (patch)
tree9f1f3116a0f7441a342c669b3b0ee959b9de598a
parentmail-client/thunderbird: define PYTHON_COMPAT in ebuild (diff)
downloadgentoo-af9298355290622e1ab2ec5253550e6b8196722a.tar.gz
gentoo-af9298355290622e1ab2ec5253550e6b8196722a.tar.bz2
gentoo-af9298355290622e1ab2ec5253550e6b8196722a.zip
www-client/firefox: define PYTHON_COMPAT in ebuild
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--www-client/firefox/firefox-60.2.0.ebuild5
-rw-r--r--www-client/firefox/firefox-60.2.1-r1.ebuild3
-rw-r--r--www-client/firefox/firefox-62.0-r1.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-60.2.0.ebuild b/www-client/firefox/firefox-60.2.0.ebuild
index b32f7700abe8..41fc75c69ea9 100644
--- a/www-client/firefox/firefox-60.2.0.ebuild
+++ b/www-client/firefox/firefox-60.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,6 +6,9 @@ VIRTUALX_REQUIRED="pgo"
WANT_AUTOCONF="2.1"
MOZ_ESR="1"
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='ncurses,sqlite,ssl,threads'
+
# This list can be updated with scripts/get_langs.sh from the mozilla overlay
MOZ_LANGS=( ach af an ar as ast az bg bn-BD bn-IN br bs ca cak cs cy da de dsb
el en en-GB en-US en-ZA eo es-AR es-CL es-ES es-MX et eu fa ff fi fr fy-NL ga-IE
diff --git a/www-client/firefox/firefox-60.2.1-r1.ebuild b/www-client/firefox/firefox-60.2.1-r1.ebuild
index 36964cc42d08..ac27525a4e80 100644
--- a/www-client/firefox/firefox-60.2.1-r1.ebuild
+++ b/www-client/firefox/firefox-60.2.1-r1.ebuild
@@ -6,6 +6,9 @@ VIRTUALX_REQUIRED="pgo"
WANT_AUTOCONF="2.1"
MOZ_ESR="1"
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='ncurses,sqlite,ssl,threads'
+
# This list can be updated with scripts/get_langs.sh from the mozilla overlay
MOZ_LANGS=( ach af an ar as ast az bg bn-BD bn-IN br bs ca cak cs cy da de dsb
el en en-GB en-US en-ZA eo es-AR es-CL es-ES es-MX et eu fa ff fi fr fy-NL ga-IE
diff --git a/www-client/firefox/firefox-62.0-r1.ebuild b/www-client/firefox/firefox-62.0-r1.ebuild
index 61b4fa494931..836fdd49f2ce 100644
--- a/www-client/firefox/firefox-62.0-r1.ebuild
+++ b/www-client/firefox/firefox-62.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -6,7 +6,7 @@ VIRTUALX_REQUIRED="pgo"
WANT_AUTOCONF="2.1"
MOZ_ESR=""
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
PYTHON_REQ_USE='ncurses,sqlite,ssl,threads'
# This list can be updated with scripts/get_langs.sh from the mozilla overlay