summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 11:36:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 12:32:45 +0300
commitafcd0aa35c37685639f8786dc50356cb3d9cfed9 (patch)
tree45b350478060910a35e36cf144f7df89f7b29988
parentdev-python/cfn-lint: add 0.61.4 (diff)
downloadgentoo-afcd0aa3.tar.gz
gentoo-afcd0aa3.tar.bz2
gentoo-afcd0aa3.zip
dev-python/botocore: add 1.27.41
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.41.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c58306720607..05b4bf605ec1 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.27.31.tar.gz 9184651 BLAKE2B 01dcd9e94490923f7d0f463d3019007f58c
DIST botocore-1.27.36.gh.tar.gz 9465835 BLAKE2B c22c341d6e762316f3d8719bd8c1fd52140642739361a7ade326d739005dbd141a6b4e1798287b40bf7ba40cd5e158d36f195893d529f5ba375b06087d2122b9 SHA512 09ef156b3c0457ceef341bf26e3f060d3e91808f1da66d1dbb06ba2826be3c61e047383dc9d8a719bb8e172e91f6475f4613c14d30c57c6a909b51c8ba7334cc
DIST botocore-1.27.37.gh.tar.gz 9466348 BLAKE2B 56c670e22204dcd12164094d52b1ed4ec820241f1423738e008f24762a5702149f2eb57283ec194a77cc2d57bc1183d91a90ca55ae0cf977aa1abdacb922ed86 SHA512 adb18c54a757077f7cff4b9b6716d015998432faeb3eb7d0a631631e5b0cf7814b40843ba379841cef920d3eca1367623f52491f53fed9f318898b3a6197eac9
DIST botocore-1.27.40.gh.tar.gz 9491717 BLAKE2B 4c4e96969432426b711642265573b1a3026ea60dbee2328ff34f0c64ad5c911bb773078e8f86882c94abc2b340567e65475ebed146651e92307ddf1629cbe2a0 SHA512 03d174f3c8490470a40ba54568b3ec1fed740acae143964db0618e7d57fd03fd6aae992d7e9dfe3882eae70a082a6974d3356cd7e2c49625eec8270fcb2ef784
+DIST botocore-1.27.41.gh.tar.gz 9493802 BLAKE2B dff510a658e77fe7185a8d118228cd80d06ea066328d39c56eaa8f01459dd11131ca73dcfe464a5e1403f8aceaa96065d5ea335bb268155c81c9b71299488d45 SHA512 29f419c4338e37bcc7fce38836b1f3b0ed1e552ea94cbe77ea09cd18c3c0b80d3405cd4a3468570c7eb6f1301bfed0d26dcc98feb7a1f62b9e8b1b11c61cdac5
diff --git a/dev-python/botocore/botocore-1.27.41.ebuild b/dev-python/botocore/botocore-1.27.41.ebuild
new file mode 100644
index 000000000000..6558cbe56a50
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.41.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}