summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-29 16:14:16 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-29 16:53:15 -0400
commitafcfe012bc1f8120630684d79075951d4cad462e (patch)
treed4fd16949acda2a49f597b278f15393b47c3d225
parentgames-action/chromium-bsu: drop 0.9.15.1-r1 (diff)
downloadgentoo-afcfe012.tar.gz
gentoo-afcfe012.tar.bz2
gentoo-afcfe012.zip
games-arcade/xscavenger: drop 1.4.4-r2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-arcade/xscavenger/Manifest1
-rw-r--r--games-arcade/xscavenger/files/1.4.4-gentoo.patch198
-rw-r--r--games-arcade/xscavenger/xscavenger-1.4.4-r2.ebuild51
3 files changed, 0 insertions, 250 deletions
diff --git a/games-arcade/xscavenger/Manifest b/games-arcade/xscavenger/Manifest
index 06d5580484f1..613e7aa425d5 100644
--- a/games-arcade/xscavenger/Manifest
+++ b/games-arcade/xscavenger/Manifest
@@ -1,3 +1,2 @@
-DIST xscavenger-1.4.4.tgz 193346 BLAKE2B eb86b97fad8a9d261935579d298f43e7063fbd0624e8fd654c72b4130e98db38541d54c59938375c8d6df4b50193436f86826c49b8bafe123b4be5c80d3f75d8 SHA512 5f200912b9114ea0c09f0bfcc3f06be2e7c2e1700a744319081f5f3a22c8b93663477076af27837326acf9830af6f597cf8f8fb44562db7d00128321487841ec
DIST xscavenger-1.4.5.tgz 192990 BLAKE2B 5df2ca8b7b331d9c17ef8f287a8967f4f95a8737660fb42e4f5012f00ab24698d555e3f76bd82f3ba7b55423244e9d0a4392ccce99c84bed6cf80dee15ab3bf6 SHA512 ebdde5c74409dc881503ee6eeecb7194218141c6e7c169c2febd1a4339625e1532a654fc1ac2ce7b3256e8a721f656dfb7bddc4394e0513a5130e3cc8795dfe7
DIST xscavenger.png 3096 BLAKE2B c1e346a2950affdd41bf89358d9138196af7a5c422e64a863f9480b9876320ff381cbd301be644d02013754552303e2141a0962b2dcc16bddc6d0a2c646405d7 SHA512 9a9a8f70baac35d0818c6d34d6af0420db27e5f44cd0072e14d520d4f142ad41f5234868cda4cd0a03157987e2fc030df552ac37b02d07934c4de0c7c8b46947
diff --git a/games-arcade/xscavenger/files/1.4.4-gentoo.patch b/games-arcade/xscavenger/files/1.4.4-gentoo.patch
deleted file mode 100644
index 4c51b37d2157..000000000000
--- a/games-arcade/xscavenger/files/1.4.4-gentoo.patch
+++ /dev/null
@@ -1,198 +0,0 @@
---- a/Imakefile
-+++ b/Imakefile
-@@ -1,20 +1,36 @@
- # set this to the path where data files should be stored. LIBDIR
- # is automatically defined by imake, usually to /usr/X11R6/lib/X11, so
- # this should be a good default.
--LIBNAME = $(LIBDIR)/scavenger
-+LIBNAME = GENTOO_DATADIR/scavenger
-
- SRCS = anim.c edit.c scav.c x.c sound.c
- OBJS = $(SRCS:.c=.o)
-
-+# the "subst" hack below is because imake uses the C preprocessor, which
-+# will interpret an unquoted "/*" as a comment beginning.
-+#LIB_DATA = $(subst S,/,..SdataS*)
- LIB_DATA = \
-- ../data/badguy.lbm ../data/brownblue.lbm ../data/death.raw \
-- ../data/dig.raw ../data/fall.raw ../data/levels.scl \
-- ../data/microman.lbm ../data/pop.raw ../data/redbrick.lbm \
-- ../data/reddevil.lbm ../data/regularguy.lbm ../data/spiralthing.lbm \
-+ ../data/badguy.lbm \
-+ ../data/brownblue.lbm \
-+ ../data/death.raw \
-+ ../data/dig.raw \
-+ ../data/fall.raw \
-+ ../data/flashspiral.lbm \
-+ ../data/gems.lbm \
-+ ../data/jungle.lbm \
-+ ../data/levels.scl \
-+ ../data/microman.lbm \
-+ ../data/pop.raw \
-+ ../data/redbrick.lbm \
-+ ../data/reddevil.lbm \
-+ ../data/regularguy.lbm \
-+ ../data/spiralthing.lbm \
- ../data/victory.raw
-
- LOCAL_LIBRARIES = $(XLIB)
- EXTRA_DEFINES = -DLIBNAME=\"$(LIBNAME)\"
-
--ComplexProgramTarget(scavenger)
-+AllTarget(scavenger)
-+NormalProgramTarget(scavenger,$(OBJS),,,$(XLIB))
-+InstallProgram(scavenger,GENTOO_BINDIR)
- InstallMultipleFlags($(LIB_DATA),$(LIBNAME),-m 644)
---- a/scav.c
-+++ b/scav.c
-@@ -240,15 +240,19 @@
-
-
-
-+/* 14 Dec 2002: re-wrote to be more portable - don't assume two's-complement
-+ * representation for integers, and fix bug when sizeof(long) > 4.
-+ */
- long readlong()
- {
--long val1=0;
--
-- val1=myci()<<24L;
-- val1|=myci()<<16L;
-- val1|=myci()<<8;
-- val1|=myci();
-+ long val1=0;
-+ int i,j;
-
-+ for (i=0; i<4; i++) {
-+ j = myci();
-+ if (j==-1) return -1L;
-+ val1 = (val1<<8) + j;
-+ }
- return val1;
- }
- int rbs()
-@@ -309,7 +313,7 @@
- bmw=bmh=byteswide=0;
- while( (type=readlong()) )
- {
-- if(type==0xffffffffL) break;
-+ if(type==-1L) break;
- size=readlong();
- if(size&1) size++;
- if(type==BMHD)
-@@ -402,16 +406,16 @@
- input=open(resourcename,O_RDONLY);
- if(input<0) return -1;
- got=read(input,buff,8);
-- if(got!=8) return -2;
-- if (strncmp(buff,"SCAV",4)) return -3;
-+ if(got!=8) {close(input);return -2;}
-+ if (strncmp(buff,"SCAV",4)) {close(input);return -3;}
- max=(buff[4]<<24) | (buff[5]<<16) | (buff[6]<<8) | buff[7];
-- if(num>=max) return 0;
-+ if(num>=max) {close(input);return 0;}
- lseek(input,(num+1)<<3,SEEK_SET);
- got=read(input,buff,8);
- offset=(buff[0]<<24) | (buff[1]<<16) | (buff[2]<<8) | buff[3];
- length=(buff[4]<<24) | (buff[5]<<16) | (buff[6]<<8) | buff[7];
- if(len>length) len=length;
-- if(!offset || !len) return 0;
-+ if(!offset || !len) {close(input);return 0;}
- lseek(input,offset,SEEK_SET);
- got=read(input,put,len);
- close(input);
-@@ -448,8 +452,8 @@
- input=open(resourcename,O_RDONLY);
- if(input==-1) return -4;
- got=read(input,buff,8);
-- if(got!=8) return -2;
-- if(strncmp(buff,"SCAV",4)) return -3;
-+ if(got!=8) {close(input);return -2;}
-+ if(strncmp(buff,"SCAV",4)) {close(input);return -3;}
- output=creat(bakname,00600);
- if(output==-1) {close(input);return -6;}
-
-@@ -473,12 +477,12 @@
- for(i=0;i<max;i++)
- if(headers[i+i])
- headers[i+i]+=delta;
-- if (write(output,"SCAV",4) != 4) return -200;
-- if (!rlout(output,max)) return -200;
-+ if (write(output,"SCAV",4) != 4) {close(input);close(output);return -200;}
-+ if (!rlout(output,max)) {close(input);close(output);return -200;}
- headers[num+num]=0;
- headers[num+num+1]=len;
- for(i=0;i<max+max;i++)
-- if (!rlout(output,headers[i])) return -200;
-+ if (!rlout(output,headers[i])) {close(input);close(output);return -200;}
-
- if(offset)
- {
-@@ -487,8 +491,8 @@
- while(count)
- {
- got=count>1024 ? 1024 : count;
-- if (read(input,copybuff,got) != got) return -200;
-- if (write(output,copybuff,got) != got) return -200;
-+ if (read(input,copybuff,got) != got) {close(input);close(output);return -200;}
-+ if (write(output,copybuff,got) != got) {close(input);close(output);return -200;}
- count-=got;
- }
- lseek(input,length,SEEK_CUR);
-@@ -498,17 +502,17 @@
- {
- got=read(input, copybuff, 1024);
- if (!got) break;
-- if (write (output, copybuff, got) != got) return -200;
-+ if (write (output, copybuff, got) != got) {close(input);close(output);return -200;}
- offset += got;
- }
- if(len)
- {
-- if (write (output, take, len) != len) return -200;
-+ if (write (output, take, len) != len) {close(input);close(output);return -200;}
- lseek (output, (num+1) << 3, SEEK_SET);
-- if (!rlout (output, offset)) return -200;
-+ if (!rlout (output, offset)) {close(input);close(output);return -200;}
- }
- close (input);
-- if (fsync(output)) return -200;
-+ if (fsync(output)) {close(output);return -200;}
- if (close(output)) return -200;
- err=rename(bakname,resourcename);
- if(err) return -1;
-@@ -1382,6 +1386,7 @@
- break;
- }
- }
-+ close(file);
- }
-
- void remslash(char *str)
-@@ -1416,6 +1421,8 @@
- return -3;
- }
- } while(len);
-+ close(input);
-+ close(output);
- return 0;
- }
-
-@@ -1448,7 +1455,7 @@
- printf("Failed to create directory %s, exiting\n",temp);
- exit(1);
- }
-- }
-+ } else close(file);
-
- sprintf(resourcename,"%s/%s/%s",localname,localdirname,LEVELSNAME);
- file=open(resourcename,O_RDONLY);
-@@ -1485,7 +1492,7 @@
- printf("Couldn't create %s\n",temp);
- exit(1);
- }
-- }
-+ } else close(file);
- }
-
- void makercname(char *str)
diff --git a/games-arcade/xscavenger/xscavenger-1.4.4-r2.ebuild b/games-arcade/xscavenger/xscavenger-1.4.4-r2.ebuild
deleted file mode 100644
index 26f6aeae2f8d..000000000000
--- a/games-arcade/xscavenger/xscavenger-1.4.4-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop toolchain-funcs
-
-DESCRIPTION="Lode-Runner-like arcade game"
-HOMEPAGE="http://www.xdr.com/dash/scavenger.html"
-SRC_URI="http://www.xdr.com/dash/${P}.tgz"
-S="${WORKDIR}/${P}/src"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND=">=x11-misc/imake-1.0.8-r1"
-RDEPEND="x11-libs/libXext"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-gentoo.patch"
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e "s:GENTOO_DATADIR:/usr/share:" \
- -e "s:GENTOO_BINDIR:/usr/bin:" \
- Imakefile \
- || die
-}
-
-src_configure() {
- CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- EXTRA_LDOPTIONS="${LDFLAGS}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ../{CREDITS,DOC,README,TODO,changelog}
- make_desktop_entry scavenger "XScavenger"
-}