summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-30 09:26:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-30 09:27:06 +0000
commitafee7f71b7f8537efb7903f019b53746618db882 (patch)
tree89a5ab1704124386c12bb388f7b0fc72b2dc502c
parentx11-plugins/wmcube: fix build with -fno-common (diff)
downloadgentoo-afee7f71b7f8537efb7903f019b53746618db882.tar.gz
gentoo-afee7f71b7f8537efb7903f019b53746618db882.tar.bz2
gentoo-afee7f71b7f8537efb7903f019b53746618db882.zip
app-emulation/simh: drop deprecated USE_NETWORK=1
Follow the suggestion from https://github.com/simh/simh/issues/15 to drop USE_NETWORK=1. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-emulation/simh/simh-3.11.0.ebuild2
-rw-r--r--app-emulation/simh/simh-3.9.0-r1.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/app-emulation/simh/simh-3.11.0.ebuild b/app-emulation/simh/simh-3.11.0.ebuild
index 5c9e5593eacc..3be97ccd83eb 100644
--- a/app-emulation/simh/simh-3.11.0.ebuild
+++ b/app-emulation/simh/simh-3.11.0.ebuild
@@ -42,7 +42,7 @@ src_compile() {
export LDFLAGS_O="${LDFLAGS}"
export CFLAGS_O="${CFLAGS}"
- local my_makeopts="USE_NETWORK=1"
+ local my_makeopts=""
if tc-is-gcc && ver_test $(gcc-version) -lt 4.6 ; then
my_makeopts+=" NO_LTO=1"
fi
diff --git a/app-emulation/simh/simh-3.9.0-r1.ebuild b/app-emulation/simh/simh-3.9.0-r1.ebuild
index ee884176530e..dcf25c3cb9cd 100644
--- a/app-emulation/simh/simh-3.9.0-r1.ebuild
+++ b/app-emulation/simh/simh-3.9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -40,7 +40,7 @@ src_compile() {
export LDFLAGS_O="${LDFLAGS}"
export CFLAGS_O="${CFLAGS}"
- local my_makeopts="USE_NETWORK=1"
+ local my_makeopts=""
if [ "$(gcc-major-version)" -le "4" -a "$(gcc-minor-version)" -lt "6" ] ; then
my_makeopts+=" NO_LTO=1"
fi