summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-28 04:17:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-28 04:24:46 +0100
commitaff8b73ad64d20a6c72a3bba2bca362775e1aa45 (patch)
tree71276ffbaf4215b06d1c43cac79bc4f09e6e7436
parentdev-python/dill: Bump to 0.3.8 (diff)
downloadgentoo-aff8b73ad64d20a6c72a3bba2bca362775e1aa45.tar.gz
gentoo-aff8b73ad64d20a6c72a3bba2bca362775e1aa45.tar.bz2
gentoo-aff8b73ad64d20a6c72a3bba2bca362775e1aa45.zip
dev-python/setuptools-gettext: Bump to 0.1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools-gettext/Manifest1
-rw-r--r--dev-python/setuptools-gettext/setuptools-gettext-0.1.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/setuptools-gettext/Manifest b/dev-python/setuptools-gettext/Manifest
index e9dc29e14b32..7d2a1dd08bfe 100644
--- a/dev-python/setuptools-gettext/Manifest
+++ b/dev-python/setuptools-gettext/Manifest
@@ -1 +1,2 @@
DIST setuptools-gettext-0.1.8.tar.gz 15548 BLAKE2B 4e1dcd219fca132e859a44e7ab86f0c81ac2dfccf5d2aca89ac05a2a3a50fec715a5e23e44173e741330d874d1f721ac8ec9d73d79b586ab605fb281aba8aafe SHA512 55b6512061565f210596972db3033d3d4f555428d23d1cac93feb3ea540461e908585d13157bcf97335f07b5a86e0b823b15457fe2f107ffc49e2e1b0c7a0c1e
+DIST setuptools-gettext-0.1.9.tar.gz 14490 BLAKE2B a233bb41124d2e927adc24aace620e7c9cd1dfd6e0a2f39343f2d9aaded434f87f2c106ddc19446cc9f4ebf39940091a93fc1375db22c8988e63425e3a5ebdde SHA512 7995c6b980429fba69aa6da2451d1cafb5035bdc02820c6ef729683d0689df594bd66a69fe142cf9f0f70f26858414a30cd9050180f9f1fdf8e81ea53bfcbbda
diff --git a/dev-python/setuptools-gettext/setuptools-gettext-0.1.9.ebuild b/dev-python/setuptools-gettext/setuptools-gettext-0.1.9.ebuild
new file mode 100644
index 000000000000..f984938a417c
--- /dev/null
+++ b/dev-python/setuptools-gettext/setuptools-gettext-0.1.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Setuptools plugin for building mo files"
+HOMEPAGE="
+ https://pypi.org/project/setuptools-gettext/
+ https://github.com/breezy-team/setuptools-gettext
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+python_test() {
+ cd example || die
+ distutils_pep517_install "${T}/${EPYTHON}"
+ if [[ ! -f ${T}/${EPYTHON}/usr/share/locale/nl/LC_MESSAGES/hallowereld.mo ]]
+ then
+ die ".mo file not installed"
+ fi
+}