summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-06 13:51:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-06 13:51:33 +0200
commitb015c7f386345fbf446cb1742d9eb037e8fbcf48 (patch)
treea718edbbb9f535fb8e3d746e7cb63140d7756cbc
parenteclass/vim-{doc,plugin}.eclass: revert previous commit. (diff)
downloadgentoo-b015c7f386345fbf446cb1742d9eb037e8fbcf48.tar.gz
gentoo-b015c7f386345fbf446cb1742d9eb037e8fbcf48.tar.bz2
gentoo-b015c7f386345fbf446cb1742d9eb037e8fbcf48.zip
app-emacs/org-superstar-mode: new package; add version 1.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/org-superstar-mode/Manifest1
-rw-r--r--app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el3
-rw-r--r--app-emacs/org-superstar-mode/metadata.xml13
-rw-r--r--app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild23
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/org-superstar-mode/Manifest b/app-emacs/org-superstar-mode/Manifest
new file mode 100644
index 000000000000..cd929d6b7a55
--- /dev/null
+++ b/app-emacs/org-superstar-mode/Manifest
@@ -0,0 +1 @@
+DIST org-superstar-mode-1.5.0.tar.gz 622275 BLAKE2B 03c3b652d422d145e916dce02e3e0d7dc0583090803984da67c7e06aae6c3f3a7bfed43bb88fdc2891703cfca6adddf29135f6e93241b137a83d85c7ae165b03 SHA512 3c8f8168011c7f5df96620af6d12d3ab093f994c2875042e88b8f132ce7c44c42b86fd6502f050c0cf5375f986252bc5e45125f08a97db9b8ed0cd5bcd8548bd
diff --git a/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el b/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el
new file mode 100644
index 000000000000..0c65805a0407
--- /dev/null
+++ b/app-emacs/org-superstar-mode/files/50org-superstar-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'org-superstar-mode "org-superstar"
+ "Use UTF8 bullets for headlines and plain lists." t)
diff --git a/app-emacs/org-superstar-mode/metadata.xml b/app-emacs/org-superstar-mode/metadata.xml
new file mode 100644
index 000000000000..921a094acd19
--- /dev/null
+++ b/app-emacs/org-superstar-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/integral-dw/org-superstar-mode/issues/</bugs-to>
+ <remote-id type="github">integral-dw/org-superstar-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild b/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild
new file mode 100644
index 000000000000..89f453b5e044
--- /dev/null
+++ b/app-emacs/org-superstar-mode/org-superstar-mode-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Prettify headings and plain lists in Org mode (use UTF8 bullets)"
+HOMEPAGE="https://github.com/integral-dw/org-superstar-mode/"
+SRC_URI="https://github.com/integral-dw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( DEMO.org README.org demos )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake EMACS="${EMACS}" EFLAGS="${EMACSFLAGS}" -C tests
+}